summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Kulisz <debian@kulisz.net>2019-09-01 13:09:32 +0100
committerMarcin Kulisz <debian@kulisz.net>2019-09-01 13:09:32 +0100
commit518887a96674e019dc4d3e7495c888d41cdb3b1b (patch)
tree5d11f6eabcf2e6d30ed6507d166064d70ae8e52b
parente0a4f1120b3951e700587b0ddf95a34a7a0316f5 (diff)
Removing python2 dependencies
-rw-r--r--debian/control13
-rw-r--r--debian/copyright2
-rw-r--r--debian/python-fysom.docs1
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/tests/control.autodep82
-rw-r--r--debian/tests/import10
6 files changed, 3 insertions, 27 deletions
diff --git a/debian/control b/debian/control
index 070d662..589f74b 100644
--- a/debian/control
+++ b/debian/control
@@ -3,9 +3,7 @@ Maintainer: Marcin Kulisz <debian@kulisz.net>
Section: python
Priority: optional
Build-Depends: debhelper-compat (= 12),
- python-all (>= 2.6.6-3),
python3-all,
- python-setuptools (>= 0.6b3),
python3-setuptools,
dh-python
Standards-Version: 4.4.0
@@ -14,17 +12,6 @@ Homepage: https://pypi.python.org/pypi/fysom
Vcs-Git: https://salsa.debian.org/debian/python-fysom.git
Vcs-Browser: https://salsa.debian.org/debian/python-fysom
-Package: python-fysom
-Architecture: all
-Depends: ${misc:Depends},
- ${python:Depends}
-Description: pYthOn Finite State Machine
- This is standalone Python micro-framework providing a finite state machine.
- .
- Originally implemented in Java by Jake Gordon.
- .
- This is the Python 2 version of the package.
-
Package: python3-fysom
Architecture: all
Depends: ${misc:Depends},
diff --git a/debian/copyright b/debian/copyright
index 6ab42f9..54f16c6 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -7,7 +7,7 @@ Copyright: 2013-2017 Maximilien Riehl <max@riehl.io>
2011 Jake Gordon <jake@codeincomplete.com>
2011 Mansour Behabadi <mansour@oxplot.com>
Stefano
- 2014-2018 Marcin Kulisz (kuLa) <debian@kulisz.net>
+ 2014-2019 Marcin Kulisz (kuLa) <debian@kulisz.net>
License: MIT
Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal in
diff --git a/debian/python-fysom.docs b/debian/python-fysom.docs
deleted file mode 100644
index e845566..0000000
--- a/debian/python-fysom.docs
+++ /dev/null
@@ -1 +0,0 @@
-README
diff --git a/debian/rules b/debian/rules
index 551ceee..a7639be 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,4 +3,4 @@
export PYBUILD_NAME=fysom
%:
- dh $@ --with python2,python3 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
diff --git a/debian/tests/control.autodep8 b/debian/tests/control.autodep8
index b85fdae..cb8e4cf 100644
--- a/debian/tests/control.autodep8
+++ b/debian/tests/control.autodep8
@@ -1,2 +1,2 @@
-Tests: import import3
+Tests: import3
Depends: @
diff --git a/debian/tests/import b/debian/tests/import
deleted file mode 100644
index 743e1d0..0000000
--- a/debian/tests/import
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/usr/bin/env python
-from fysom import Fysom
-
-fsm = Fysom({'initial': 'green',
- 'events': [
- {'name': 'warn', 'src': 'green', 'dst': 'yellow'},
- {'name': 'panic', 'src': 'yellow', 'dst': 'red'},
- {'name': 'calm', 'src': 'red', 'dst': 'yellow'},
- {'name': 'clear', 'src': 'yellow', 'dst': 'green'}]})
-print(fsm.current)