summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2018-11-05 14:44:38 +0100
committerAndrej Shadura <andrewsh@debian.org>2018-11-05 14:44:38 +0100
commit4d73449bab819dddc8e7f52ddf01b6bacd2a7e40 (patch)
tree992d9135cdaf62c13cf05fb6bc73628b1d5c7577 /setup.py
parent8f6a863fcd6a0518ea8e3e1e863346553d0250ba (diff)
parent59c3ccc50d3504bfeb1a3f7e31ba806e2b5c3a07 (diff)
Update upstream source from tag 'upstream/0.19'
Update to upstream version '0.19' with Debian dir 0cc2866dc4222e919db114429121a55eadb99c77
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 7 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 7ef8b6c..c3b0123 100644
--- a/setup.py
+++ b/setup.py
@@ -12,26 +12,11 @@ from setuptools import setup, find_packages
VERSION = re.search(r"__version__ = '(.*?)'",
open("ofxparse/__init__.py").read()).group(1)
-# Use BeautifulSoup 3 on Python 2.5 and earlier and BeautifulSoup 4 otherwise
-if sys.version_info < (2, 6):
- REQUIRES = [
- "beautifulSoup>=3.0",
- ]
-else:
- REQUIRES = [
- "beautifulsoup4",
- "lxml",
- ]
-
-if sys.version_info < (2, 7):
- REQUIRES.extend([
- "ordereddict>=1.1",
- ])
-
-REQUIRES.extend([
+REQUIRES = [
+ "beautifulsoup4",
+ "lxml",
'six',
- 'lxml'
-])
+]
README = os.path.join(os.path.dirname(__file__), 'README.rst')
@@ -50,10 +35,11 @@ setup_params = dict(
"Intended Audience :: Developers",
"Natural Language :: English",
"Operating System :: OS Independent",
- "Programming Language :: Python :: 2.5",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Utilities",
"License :: OSI Approved :: MIT License",