summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@debian.org>2023-10-19 22:56:43 +0300
committerPeter Pentchev <roam@debian.org>2023-10-19 22:56:43 +0300
commitab6138fecdf0a7c71948d70e6c853fd36c519681 (patch)
tree3f7994314c5900a3d9d3aa2fde1a33cb441521f8
parentab8a3f744cd70d8fdeac2f6d868e924bbcc34be5 (diff)
Update to version 1 of the dpkg build API
Drop the implied R-R-R: no declaration. Include dpkg's default.mk for completeness.
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
3 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 91dc09a..7780332 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+python-parse-stages (0.1.5-2) UNRELEASED; urgency=medium
+
+ * Update the build infrastructure to version 1 of the dpkg build API:
+ - drop the implied "Rules-Requires-Root: no" declaration
+ - include default.mk for completeness
+
+ -- Peter Pentchev <roam@debian.org> Thu, 19 Oct 2023 22:53:48 +0300
+
python-parse-stages (0.1.5-1) unstable; urgency=medium
* Add a trivial git-buildpackage configuration file.
diff --git a/debian/control b/debian/control
index 8a8ed39..c443119 100644
--- a/debian/control
+++ b/debian/control
@@ -7,6 +7,7 @@ Build-Depends:
debhelper-compat (= 13),
dh-sequence-python3,
dh-sequence-single-binary,
+ dpkg-build-api (= 1),
pybuild-plugin-pyproject,
python3-all,
python3-hatch-requirements-txt,
@@ -14,7 +15,6 @@ Build-Depends:
python3-pyparsing (>> 3),
Standards-Version: 4.6.2
Homepage: https://gitlab.com/ppentchev/parse-stages
-Rules-Requires-Root: no
Vcs-Git: https://salsa.debian.org/python-team/packages/parse-stages.git
Vcs-Browser: https://salsa.debian.org/python-team/packages/parse-stages
diff --git a/debian/rules b/debian/rules
index 059f03c..729e6d6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,5 +2,7 @@
export PYBUILD_NAME=parse_stages
+include /usr/share/dpkg/default.mk
+
%:
dh '$@' --buildsystem=pybuild