summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Sprickerhof <git@jochen.sprickerhof.de>2018-12-09 19:02:37 +0100
committerJochen Sprickerhof <git@jochen.sprickerhof.de>2018-12-09 20:24:30 +0100
commit089f74ea5ad243742b55a9b0e9ea88ddbf49f754 (patch)
treea5b84ed1201a9181573cda06d8f619e854fd310d
parentf61ccbc949e9db0bef0af2c16fdb3fb111a8c002 (diff)
Add support for PCL 1.9
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0493ccc..84addab 100644
--- a/setup.py
+++ b/setup.py
@@ -510,7 +510,7 @@ else:
os.environ['ARCHFLAGS'] = ''
# Try to find PCL. XXX we should only do this when trying to build or install.
- PCL_SUPPORTED = ["-1.8", "-1.7", "-1.6", ""] # in order of preference
+ PCL_SUPPORTED = ["-1.9", "-1.8", "-1.7", "-1.6", ""] # in order of preference
for pcl_version in PCL_SUPPORTED:
if subprocess.call(['pkg-config', 'pcl_common%s' % pcl_version]) == 0:
@@ -614,6 +614,13 @@ else:
# debug
# gdb_debug=True,
]
+ elif pcl_version == '-1.9':
+ module = [Extension("pcl._pcl", ["pcl/_pcl_180.pyx", "pcl/minipcl.cpp", "pcl/ProjectInliers.cpp"], language="c++", **ext_args),
+ Extension("pcl.pcl_visualization", ["pcl/pcl_visualization.pyx"], language="c++", extra_compile_args=['-std=c++11','-fno-strict-aliasing'], **ext_args),
+ # Extension("pcl.pcl_grabber", ["pcl/pcl_grabber.pyx", "pcl/grabber_callback.cpp"], language="c++", **ext_args),
+ # debug
+ # gdb_debug=True,
+ ]
else:
print('no pcl install or pkg-config missed.')
sys.exit(1)