summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Shadura <andrew.shadura@collabora.co.uk>2017-09-14 22:28:10 +0200
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2017-09-14 22:28:49 +0200
commit1aef32edde095d903cc27e593b5919882c5ce400 (patch)
treee9bde45f7e3cacbc7170b67814c3ee5f78040740 /debian
parentff5917252efc9dc92f00ccd0c5b1f95cac8533a3 (diff)
Initial packaging.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control29
-rw-r--r--debian/copyright12
-rw-r--r--debian/gbp.conf3
-rw-r--r--debian/python-phonenumbers.docs1
-rw-r--r--debian/python3-phonenumbers.docs1
-rwxr-xr-xdebian/rules4
7 files changed, 45 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index 6109eb92..abec679f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,5 @@
-python-phonenumbers (7.0.4) UNRELEASED; urgency=low
+python-phonenumbers (8.8.1-1) UNRELEASED; urgency=low
- * Update to upstream version 7.0.4
+ * Initial release based on work of Torge Szczepanek.
- -- Torge Szczepanek <debian@cygnusnetworks.de> Mon, 04 May 2015 12:10:11 +0200
-
-python-phonenumbers (6.0.0a) UNRELEASED; urgency=low
-
- * Initial Debian packaging
-
- -- Torge Szczepanek <debian@cygnusnetworks.de> Wed, 07 May 2014 13:01:55 +0200
+ -- Andrew Shadura <andrewsh@debian.org> Thu, 14 Sep 2017 22:25:55 +0200
diff --git a/debian/control b/debian/control
index e3178ac3..776aefbe 100644
--- a/debian/control
+++ b/debian/control
@@ -1,15 +1,32 @@
Source: python-phonenumbers
Section: python
Priority: optional
-Maintainer: Torge Szczepanek <debian@cygnusnetworks.de>
-Build-Depends: debhelper (>= 9), python-all, python-setuptools
-Standards-Version: 3.9.6
+Maintainer: Andrew Shadura <andrewsh@debian.org>
+Build-Depends:
+ debhelper (>= 9),
+ dh-python,
+ python-all (>= 2.6.6-3),
+ python-setuptools (>= 0.6.24),
+ python3-all,
+ python3-setuptools (>= 0.6.24)
+Standards-Version: 4.0.0
+X-Python-Version: >= 2.7
Package: python-phonenumbers
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}
-Description: Python port of Google libphonenumber
- This is a Python port of Google's libphonenumber library, from
+Depends: ${misc:Depends}, ${python:Depends}
+Provides: ${python:Provides}
+Description: Python 2 port of Google libphonenumber
+ This is a Python 2 port of Google's libphonenumber library, from
+ https://github.com/googlei18n/libphonenumber.
+ It supports Python 2.5-2.7 and Python 3.x (in the same codebase, with
+ no 2to3 conversion needed).
+
+Package: python3-phonenumbers
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: Python 3 port of Google libphonenumber
+ This is a Python 3 port of Google's libphonenumber library, from
https://github.com/googlei18n/libphonenumber.
It supports Python 2.5-2.7 and Python 3.x (in the same codebase, with
no 2to3 conversion needed).
diff --git a/debian/copyright b/debian/copyright
index 3924437e..20532654 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -2,7 +2,10 @@ Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Source: https://github.com/daviddrysdale/python-phonenumbers
Files: *
-Copyright: 2009-2015 The Libphonenumber Authors
+Copyright:
+ 2009-2017 The Libphonenumber Authors
+ 2011—2017 David Drysdale <drysdale@google.com>
+ 2014 Artem Nezvigin <artem@artnez.com>
License: Apache-2.0
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -19,3 +22,10 @@ License: Apache-2.0
On Debian systems, the full text of the Apache License, Version 2.0 can be
found in the file
`/usr/share/common-licenses/Apache-2.0'.
+
+Files: *
+Copyright:
+ 2014 Torge Szczepanek <t.szczepanek@cygnusnetworks.de>
+ 2015 Peter Adam <p.adam@cygnusnetworks.de>
+ 2017 Andrew Shadura <andrewsh@debian.org>
+License: Apache-2.0
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 00000000..2541c07f
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,3 @@
+[DEFAULT]
+debian-branch = debian/master
+upstream-branch = upstream/latest
diff --git a/debian/python-phonenumbers.docs b/debian/python-phonenumbers.docs
new file mode 100644
index 00000000..b43bf86b
--- /dev/null
+++ b/debian/python-phonenumbers.docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/python3-phonenumbers.docs b/debian/python3-phonenumbers.docs
new file mode 100644
index 00000000..b43bf86b
--- /dev/null
+++ b/debian/python3-phonenumbers.docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/rules b/debian/rules
index 4647c9c0..f5e4f4ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,6 @@
#!/usr/bin/make -f
+export PYBUILD_NAME=phonenumbers
+
%:
- dh $@ --with python2
+ dh $@ --with python2,python3 --buildsystem=pybuild