summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2022-11-01 09:44:34 +0100
committerAndrej Shadura <andrewsh@debian.org>2022-11-01 09:44:34 +0100
commit3205a40df98420fdae0e19444066dd0c4c53339f (patch)
treebf881bdef578f316e55a89dedab640317e021983 /debian
parentb3d79efbcec7ccc9fa70d982dbd369765879c23f (diff)
Patch setup.py to use setuptools instead of distutils
Closes: #1022438
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/0001-Use-setuptools-instead-of-distutils.patch32
-rw-r--r--debian/patches/series1
2 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/0001-Use-setuptools-instead-of-distutils.patch b/debian/patches/0001-Use-setuptools-instead-of-distutils.patch
new file mode 100644
index 00000000..659f1521
--- /dev/null
+++ b/debian/patches/0001-Use-setuptools-instead-of-distutils.patch
@@ -0,0 +1,32 @@
+From: Andrej Shadura <andrewsh@debian.org>
+Date: Tue, 1 Nov 2022 09:42:34 +0100
+Subject: Use setuptools instead of distutils
+
+Bug-Debian: https://bugs.debian.org/1022438
+
+---
+ python/setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/python/setup.py b/python/setup.py
+index 8885c3e..ee10bd7 100755
+--- a/python/setup.py
++++ b/python/setup.py
+@@ -15,7 +15,7 @@
+ # See the License for the specific language governing permissions and
+ # limitations under the License.
+
+-import distutils.core
++#import distutils.core
+ import io
+ import sys
+ # Importing setuptools adds some features like "setup.py test", but
+@@ -57,7 +57,7 @@ else:
+ pkgs = ['phonenumbers', 'phonenumbers.data', 'phonenumbers.geodata', 'phonenumbers.shortdata',
+ 'phonenumbers.carrierdata', 'phonenumbers.tzdata']
+
+-distutils.core.setup(name=pkgname,
++setuptools.setup(name=pkgname,
+ version=__version__,
+ description="Python version of Google's common library for parsing, formatting, storing and validating international phone numbers.",
+ long_description=long_description,
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 00000000..f9628c42
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Use-setuptools-instead-of-distutils.patch