summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-03-12 12:43:13 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2017-03-12 13:54:48 -0700
commitc5d382cfe4c51e52e2ef9d1736dd01fb76c497a3 (patch)
treeb7109b14c7163be8df38e147321083f78f5f6429
parent2d6bc48c613c8adb9b3d492d6a0fe8175290a457 (diff)
Document and test support for Python 3.6
-rw-r--r--.travis.yml22
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
3 files changed, 13 insertions, 16 deletions
diff --git a/.travis.yml b/.travis.yml
index db8c283..3f0687c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,6 +1,7 @@
language: python
-python: '3.5'
+python: 3.6
sudo: false
+cache: pip
env:
global:
- LD_PRELOAD=/lib/x86_64-linux-gnu/libSegFault.so
@@ -8,19 +9,19 @@ env:
matrix:
- TOXENV=check
- TOXENV=docs
-
- TOXENV=py26,coveralls,codecov
-
- TOXENV=py27,coveralls,codecov
-
- TOXENV=py33,coveralls,codecov
-
- TOXENV=py34,coveralls,codecov
-
- - TOXENV=py35,coveralls,codecov
-
+ - TOXENV=py36,coveralls,codecov
- TOXENV=pypy,coveralls,codecov
+matrix:
+ include:
+ - python: 3.5
+ env:
+ - TOXENV=py35,coveralls,codecov
+
before_install:
- python --version
- uname -a
@@ -36,11 +37,6 @@ script:
after_failure:
- more .tox/log/* | cat
- more .tox/*/log/* | cat
-before_cache:
- - rm -rf $HOME/.cache/pip/log
-cache:
- directories:
- - $HOME/.cache/pip
notifications:
email:
on_success: never
diff --git a/setup.py b/setup.py
index c4566b8..57cf6c1 100644
--- a/setup.py
+++ b/setup.py
@@ -54,6 +54,7 @@ setup(
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Utilities',
diff --git a/tox.ini b/tox.ini
index bf22f8e..2b6e0e0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@
envlist =
clean,
check,
- {py26,py27,py33,py34,py35,pypy},
+ {py26,py27,py33,py34,py35,py36,pypy},
report,
docs
@@ -16,7 +16,8 @@ basepython =
py33: {env:TOXPYTHON:python3.3}
py34: {env:TOXPYTHON:python3.4}
py35: {env:TOXPYTHON:python3.5}
- {clean,check,report,coveralls,codecov}: python3.5
+ py36: {env:TOXPYTHON:python3.6}
+ {clean,check,report,coveralls,codecov}: python3.6
bootstrap: python
setenv =
PYTHONPATH={toxinidir}/tests
@@ -107,4 +108,3 @@ commands =
commands = coverage erase
skip_install = true
deps = coverage
-