summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2023-06-28 22:44:06 +0100
committerColin Watson <cjwatson@debian.org>2023-06-28 22:44:06 +0100
commit0f96ae90f194236823aa97e709f6b4935fbd69b3 (patch)
tree6558626ee51d81a80475a45ec809d8b0cabfbe50 /setup.py
parentbe15a5ec8a45c072c2262e3a7ce598004f8739cf (diff)
New upstream version 2.0.0
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py37
1 files changed, 14 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index 9193b68..f47d250 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -1,43 +1,31 @@
#!/usr/bin/env python
-# -*- encoding: utf-8 -*-
-from __future__ import absolute_import
-from __future__ import print_function
-
-import io
import re
-from glob import glob
-from os.path import basename
-from os.path import dirname
-from os.path import join
-from os.path import splitext
+from pathlib import Path
from setuptools import find_packages
from setuptools import setup
def read(*names, **kwargs):
- with io.open(
- join(dirname(__file__), *names),
- encoding=kwargs.get('encoding', 'utf8')
- ) as fh:
+ with Path(__file__).parent.joinpath(*names).open(encoding=kwargs.get('encoding', 'utf8')) as fh:
return fh.read()
setup(
name='tblib',
- version='1.7.0',
+ version='2.0.0',
license='BSD-2-Clause',
description='Traceback serialization library.',
- long_description='%s\n%s' % (
+ long_description='{}\n{}'.format(
re.compile('^.. start-badges.*^.. end-badges', re.M | re.S).sub('', read('README.rst')),
- re.sub(':[a-z]+:`~?(.*?)`', r'``\1``', read('CHANGELOG.rst'))
+ re.sub(':[a-z]+:`~?(.*?)`', r'``\1``', read('CHANGELOG.rst')),
),
author='Ionel Cristian Mărieș',
author_email='contact@ionelmc.ro',
url='https://github.com/ionelmc/python-tblib',
packages=find_packages('src'),
package_dir={'': 'src'},
- py_modules=[splitext(basename(path))[0] for path in glob('src/*.py')],
+ py_modules=[path.stem for path in Path('src').glob('*.py')],
include_package_data=True,
zip_safe=False,
classifiers=[
@@ -49,12 +37,13 @@ setup(
'Operating System :: POSIX',
'Operating System :: Microsoft :: Windows',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
# uncomment if you test on these interpreters:
@@ -69,9 +58,11 @@ setup(
'Issue Tracker': 'https://github.com/ionelmc/python-tblib/issues',
},
keywords=[
- 'traceback', 'debugging', 'exceptions',
+ 'traceback',
+ 'debugging',
+ 'exceptions',
],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
+ python_requires='>=3.7',
install_requires=[
# eg: 'aspectlib==1.1.1', 'six>=1.7',
],