summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-10-24 13:40:27 +0100
committerColin Watson <cjwatson@debian.org>2019-10-24 13:40:27 +0100
commit1b170095f3e7d03666d8e672d3ad62355a5240dc (patch)
treef3660f04c21884ca15559794f9d62c8d11e0924e /setup.py
parent6ee4c027ff1501a7fe68f03ba94846ef614137b2 (diff)
New upstream version 1.5.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index d6f2fb2..467a486 100644
--- a/setup.py
+++ b/setup.py
@@ -25,8 +25,8 @@ def read(*names, **kwargs):
setup(
name='tblib',
- version='1.4.0',
- license='BSD 2-Clause License',
+ version='1.5.0',
+ license='BSD-2-Clause',
description='Traceback serialization library.',
long_description='%s\n%s' % (
re.compile('^.. start-badges.*^.. end-badges', re.M | re.S).sub('', read('README.rst')),
@@ -51,10 +51,10 @@ setup(
'Programming Language :: Python',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
# uncomment if you test on these interpreters:
@@ -71,7 +71,7 @@ setup(
keywords=[
'traceback', 'debugging', 'exceptions',
],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
install_requires=[
# eg: 'aspectlib==1.1.1', 'six>=1.7',
],