summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIonel Cristian Mărieș <contact@ionelmc.ro>2013-12-31 02:07:24 +0200
committerIonel Cristian Mărieș <contact@ionelmc.ro>2013-12-31 02:07:24 +0200
commitbf5dd770120acde9eacb502d39ed63ee2997e564 (patch)
tree12af26627f4ba2584ba09df27d7638d0899df12a /setup.py
Initial.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..64cb967
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,38 @@
+# -*- encoding: utf8 -*-
+from setuptools import setup, find_packages
+
+import os
+
+setup(
+ name = "tblib",
+ version = "0.0.1",
+ url = 'https://github.com/ionelmc/python-tblib',
+ download_url = '',
+ license = 'BSD',
+ description = "Traceback fiddling library.",
+ long_description = open(os.path.join(os.path.dirname(__file__), 'README.rst')).read(),
+ author = 'Ionel Cristian Mărieș',
+ author_email = 'contact@ionelmc.ro',
+ package_dir = {'':'src'},
+ py_modules = ['pth'],
+ include_package_data = True,
+ zip_safe = False,
+ classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: Unix',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Debuggers',
+ 'Topic :: Utilities',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ ],
+ install_requires=[
+ 'six',
+ ]
+)