summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2023-06-28 22:44:06 +0100
committerColin Watson <cjwatson@debian.org>2023-06-28 22:44:06 +0100
commit0f96ae90f194236823aa97e709f6b4935fbd69b3 (patch)
tree6558626ee51d81a80475a45ec809d8b0cabfbe50 /tox.ini
parentbe15a5ec8a45c072c2262e3a7ce598004f8739cf (diff)
New upstream version 2.0.0
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini44
1 files changed, 17 insertions, 27 deletions
diff --git a/tox.ini b/tox.ini
index e052f92..8afc240 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,34 +1,34 @@
[testenv:bootstrap]
deps =
jinja2
- matrix
tox
skip_install = true
commands =
python ci/bootstrap.py --no-env
passenv =
*
-; a generative tox configuration, see: https://tox.readthedocs.io/en/latest/config.html#generative-envlist
+; a generative tox configuration, see: https://tox.wiki/en/latest/user_guide.html#generative-environments
[tox]
envlist =
clean,
check,
docs,
- {py27,py35,py36,py37,py38,pypy,pypy3},
+ {py37,py38,py39,py310,py311,pypy37,pypy38,pypy39},
report
ignore_basepython_conflict = true
[testenv]
basepython =
- pypy: {env:TOXPYTHON:pypy}
- pypy3: {env:TOXPYTHON:pypy3}
- py27: {env:TOXPYTHON:python2.7}
- py35: {env:TOXPYTHON:python3.5}
- py36: {env:TOXPYTHON:python3.6}
+ pypy37: {env:TOXPYTHON:pypy3.7}
+ pypy38: {env:TOXPYTHON:pypy3.8}
+ pypy39: {env:TOXPYTHON:pypy3.9}
py37: {env:TOXPYTHON:python3.7}
py38: {env:TOXPYTHON:python3.8}
- {bootstrap,clean,check,report,codecov,docs}: {env:TOXPYTHON:python3}
+ py39: {env:TOXPYTHON:python3.9}
+ py310: {env:TOXPYTHON:python3.10}
+ py311: {env:TOXPYTHON:python3.11}
+ {bootstrap,clean,check,report,docs,codecov}: {env:TOXPYTHON:python3}
setenv =
PYTHONPATH={toxinidir}/tests
PYTHONUNBUFFERED=yes
@@ -37,28 +37,23 @@ passenv =
usedevelop = false
deps =
pytest
- pytest-travis-fold
pytest-cov
- pytest-clarity
- six
- py{27,35,36,37,38,py,py3}: twisted
commands =
- {posargs:py.test --cov=tblib --cov-report=term-missing -vv tests README.rst}
+ {posargs:pytest --cov --cov-report=term-missing --cov-report=xml -vv tests}
[testenv:check]
deps =
docutils
check-manifest
- flake8
+ pre-commit
readme-renderer
pygments
isort
skip_install = true
commands =
python setup.py check --strict --metadata --restructuredtext
- check-manifest {toxinidir}
- flake8 src tests setup.py
- isort --verbose --check-only --diff --recursive src tests setup.py
+ check-manifest .
+ pre-commit run --all-files --show-diff-on-failure
[testenv:docs]
usedevelop = true
@@ -68,15 +63,9 @@ commands =
sphinx-build {posargs:-E} -b html docs dist/docs
sphinx-build -b linkcheck docs dist/docs
-[testenv:codecov]
-deps =
- codecov
-skip_install = true
-commands =
- codecov []
-
[testenv:report]
-deps = coverage
+deps =
+ coverage
skip_install = true
commands =
coverage report
@@ -85,4 +74,5 @@ commands =
[testenv:clean]
commands = coverage erase
skip_install = true
-deps = coverage
+deps =
+ coverage