summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorIonel Cristian Mărieș <contact@ionelmc.ro>2015-10-02 22:42:08 +0300
committerIonel Cristian Mărieș <contact@ionelmc.ro>2015-10-02 22:42:08 +0300
commit8d04e68fdac7ddf9f34f3d2f11f5f305815ef789 (patch)
tree8ada746468eb93994e805c0b893f43517f1592f0 /tox.ini
parent7331663ecd68cee8f0310f87aaf257fb24a9e976 (diff)
Upgrade skel.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini143
1 files changed, 104 insertions, 39 deletions
diff --git a/tox.ini b/tox.ini
index 81b6a64..7b46a80 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,52 +1,117 @@
+; a generative tox configuration, see: https://testrun.org/tox/latest/config.html#generative-envlist
+
[tox]
envlist =
- py,
- py2.7,
- py3,
- py3.2,
- py3.3,
- py3.4,
- pypy
+ clean,
+ check,
+ {2.6,2.7,3.3,3.4,pypy}-{cover,nocov},
+ report,
+ docs
[testenv]
+basepython =
+ pypy: {env:TOXPYTHON:pypy}
+ 2.6: {env:TOXPYTHON:python2.6}
+ {2.7,docs,spell}: {env:TOXPYTHON:python2.7}
+ 3.3: {env:TOXPYTHON:python3.3}
+ 3.4: {env:TOXPYTHON:python3.4}
+ {clean,check,report,extension-coveralls,coveralls,codecov}: python3.4
setenv =
- PYTHONPATH = {toxinidir}/src:{toxinidir}/tests
- WITH_COVERAGE = x
- PYTHONUNBUFFERED = x
-commands = {envpython} {toxinidir}/tests/test_tblib.py
-
-[base]
+ PYTHONPATH={toxinidir}/tests
+ PYTHONUNBUFFERED=yes
+passenv =
+ *
deps =
- coverage
- ;nose
- ;yanc
- ;nose-timelimit
+ six
+ cover: coverage
+commands =
+ cover: {posargs:coverage run {toxinidir}/tests/test_tblib.py}
+ nocov: {posargs:{envpython} {toxinidir}/tests/test_tblib.py}
+usedevelop = true
-[testenv:py]
-basepython = python
+[testenv:spell]
+setenv =
+ SPELLCHECK=1
+commands =
+ sphinx-build -b spelling docs dist/docs
+skip_install = true
+usedevelop = true
deps =
- {[base]deps}
-[testenv:py2.7]
-basepython = python2.7
+ -r{toxinidir}/docs/requirements.txt
+ sphinxcontrib-spelling
+ pyenchant
+
+[testenv:docs]
deps =
- {[base]deps}
-[testenv:py3]
-basepython = python3
+ -r{toxinidir}/docs/requirements.txt
+commands =
+ sphinx-build {posargs:-E} -b html docs dist/docs
+ sphinx-build -b linkcheck docs dist/docs
+
+[testenv:check]
+basepython = python3.4
deps =
- {[base]deps}
-[testenv:py3.2]
-basepython = python3.2
+ docutils
+ check-manifest
+ flake8
+ readme
+ pygments
+skip_install = true
+usedevelop = false
+commands =
+ python setup.py check --strict --metadata --restructuredtext
+ check-manifest {toxinidir}
+ flake8 src tests
+
+[testenv:coveralls]
deps =
- {[base]deps}
-[testenv:py3.3]
-basepython = python3.3
+ coveralls
+skip_install = true
+usedevelop = false
+commands =
+ coverage combine
+ coverage report
+ coveralls []
+
+[testenv:codecov]
deps =
- {[base]deps}
-[testenv:py3.4]
+ codecov
+skip_install = true
+usedevelop = false
+commands =
+ coverage combine
+ coverage report
+ coverage xml --ignore-errors
+ codecov []
+
+
+[testenv:report]
basepython = python3.4
-deps =
- {[base]deps}
-[testenv:pypy]
-basepython = pypy
-deps =
- {[base]deps}
+deps = coverage
+skip_install = true
+usedevelop = false
+commands =
+ coverage combine
+ coverage report
+
+[testenv:clean]
+commands = coverage erase
+skip_install = true
+usedevelop = false
+deps = coverage
+
+[testenv:2.6-nocov]
+usedevelop = false
+
+[testenv:2.7-nocov]
+usedevelop = false
+
+[testenv:3.3-nocov]
+usedevelop = false
+
+[testenv:3.4-nocov]
+usedevelop = false
+
+[testenv:pypy-nocov]
+usedevelop = false
+