summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorIonel Cristian Mărieș <contact@ionelmc.ro>2016-03-08 13:57:47 +0200
committerIonel Cristian Mărieș <contact@ionelmc.ro>2016-03-08 13:57:47 +0200
commitc5d3a2357a974d667df9e224af2c2e3460cb53a2 (patch)
tree8d0fd92001518cb9ade1ab5dda4eca51cd35af0f /tox.ini
parentcb7a3bd7629d3aeee9851f1249f156ebc14ab79c (diff)
Upgrade skel. Add docs dir.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini68
1 files changed, 28 insertions, 40 deletions
diff --git a/tox.ini b/tox.ini
index 4ca1361..1c9d275 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,31 +4,42 @@
envlist =
clean,
check,
- {2.6,2.7,3.3,3.4,3.5,pypy}-{cover,nocov},
+ {py26,py27,py33,py34,py35,pypy},
report,
docs
[testenv]
basepython =
pypy: {env:TOXPYTHON:pypy}
- 2.6: {env:TOXPYTHON:python2.6}
- {2.7,docs,spell}: {env:TOXPYTHON:python2.7}
- 3.3: {env:TOXPYTHON:python3.3}
- 3.4: {env:TOXPYTHON:python3.4}
- 3.5: {env:TOXPYTHON:python3.5}
- {clean,check,report,extension-coveralls,coveralls,codecov}: python3.4
+ py26: {env:TOXPYTHON:python2.6}
+ {py27,docs,spell}: {env:TOXPYTHON:python2.7}
+ py33: {env:TOXPYTHON:python3.3}
+ py34: {env:TOXPYTHON:python3.4}
+ py35: {env:TOXPYTHON:python3.5}
+ {clean,check,report,coveralls,codecov}: python3.5
+ bootstrap: python
setenv =
PYTHONPATH={toxinidir}/tests
PYTHONUNBUFFERED=yes
passenv =
*
+usedevelop = false
+deps =
+ pytest
+ pytest-travis-fold
+ pytest-cov
+commands =
+ {posargs:py.test --cov=tblib --cov-report=term-missing -vv tests}
+
+[testenv:bootstrap]
deps =
- six
- cover: coverage
+ jinja2
+ matrix
+skip_install = true
commands =
- cover: {posargs:coverage run {toxinidir}/tests/test_tblib.py}
- nocov: {posargs:{envpython} {toxinidir}/tests/test_tblib.py}
-usedevelop = true
+ python ci/bootstrap.py
+passenv =
+ *
[testenv:spell]
setenv =
@@ -36,7 +47,6 @@ setenv =
commands =
sphinx-build -b spelling docs dist/docs
skip_install = true
-usedevelop = true
deps =
-r{toxinidir}/docs/requirements.txt
sphinxcontrib-spelling
@@ -50,25 +60,24 @@ commands =
sphinx-build -b linkcheck docs dist/docs
[testenv:check]
-basepython = python3.4
deps =
docutils
check-manifest
flake8
- readme
+ readme-renderer
pygments
+ isort
skip_install = true
-usedevelop = false
commands =
python setup.py check --strict --metadata --restructuredtext
check-manifest {toxinidir}
- flake8 src tests
+ flake8 src tests setup.py
+ isort --verbose --check-only --diff --recursive src tests setup.py
[testenv:coveralls]
deps =
coveralls
skip_install = true
-usedevelop = false
commands =
coverage combine
coverage report
@@ -78,7 +87,6 @@ commands =
deps =
codecov
skip_install = true
-usedevelop = false
commands =
coverage combine
coverage report
@@ -87,35 +95,15 @@ commands =
[testenv:report]
-basepython = python3.4
deps = coverage
skip_install = true
-usedevelop = false
commands =
coverage combine
coverage report
+ coverage html
[testenv:clean]
commands = coverage erase
skip_install = true
-usedevelop = false
deps = coverage
-[testenv:2.6-nocov]
-usedevelop = false
-
-[testenv:2.7-nocov]
-usedevelop = false
-
-[testenv:3.3-nocov]
-usedevelop = false
-
-[testenv:3.4-nocov]
-usedevelop = false
-
-[testenv:3.5-nocov]
-usedevelop = false
-
-[testenv:pypy-nocov]
-usedevelop = false
-