summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 17 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index be19704..d6f2fb2 100644
--- a/setup.py
+++ b/setup.py
@@ -16,16 +16,17 @@ from setuptools import setup
def read(*names, **kwargs):
- return io.open(
+ with io.open(
join(dirname(__file__), *names),
encoding=kwargs.get('encoding', 'utf8')
- ).read()
+ ) as fh:
+ return fh.read()
setup(
name='tblib',
- version='1.3.2',
- license='BSD',
+ version='1.4.0',
+ license='BSD 2-Clause License',
description='Traceback serialization library.',
long_description='%s\n%s' % (
re.compile('^.. start-badges.*^.. end-badges', re.M | re.S).sub('', read('README.rst')),
@@ -50,17 +51,27 @@ setup(
'Programming Language :: Python',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
+ # uncomment if you test on these interpreters:
+ # 'Programming Language :: Python :: Implementation :: IronPython',
+ # 'Programming Language :: Python :: Implementation :: Jython',
+ # 'Programming Language :: Python :: Implementation :: Stackless',
'Topic :: Utilities',
],
+ project_urls={
+ 'Documentation': 'https://python-tblib.readthedocs.io/',
+ 'Changelog': 'https://python-tblib.readthedocs.io/en/latest/changelog.html',
+ 'Issue Tracker': 'https://github.com/ionelmc/python-tblib/issues',
+ },
keywords=[
- # eg: 'keyword1', 'keyword2', 'keyword3',
+ 'traceback', 'debugging', 'exceptions',
],
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
install_requires=[
# eg: 'aspectlib==1.1.1', 'six>=1.7',
],