summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini52
1 files changed, 24 insertions, 28 deletions
diff --git a/tox.ini b/tox.ini
index 7f0c1de..fba49d1 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,23 +1,23 @@
-; a generative tox configuration, see: https://testrun.org/tox/latest/config.html#generative-envlist
+; a generative tox configuration, see: https://tox.readthedocs.io/en/latest/config.html#generative-envlist
[tox]
envlist =
clean,
check,
- {py27,py33,py34,py35,py36,pypy},
- report,
- docs
+ docs,
+ {py27,py34,py35,py36,py37,pypy,pypy3},
+ report
[testenv]
basepython =
pypy: {env:TOXPYTHON:pypy}
pypy3: {env:TOXPYTHON:pypy3}
- {py27,docs,spell}: {env:TOXPYTHON:python2.7}
- py33: {env:TOXPYTHON:python3.3}
+ py27: {env:TOXPYTHON:python2.7}
py34: {env:TOXPYTHON:python3.4}
py35: {env:TOXPYTHON:python3.5}
- py36: {env:TOXPYTHON:python3.6}
- {bootstrap,clean,check,report,coveralls,codecov}: {env:TOXPYTHON:python3}
+ {py36,docs,spell}: {env:TOXPYTHON:python3.6}
+ py37: {env:TOXPYTHON:python3.7}
+ {bootstrap,clean,check,report,codecov,coveralls}: {env:TOXPYTHON:python3}
setenv =
PYTHONPATH={toxinidir}/tests
PYTHONUNBUFFERED=yes
@@ -29,6 +29,7 @@ deps =
pytest-travis-fold
pytest-cov
six
+ twisted
commands =
{posargs:py.test --cov=tblib --cov-report=term-missing -vv tests README.rst}
@@ -39,8 +40,21 @@ deps =
skip_install = true
commands =
python ci/bootstrap.py
-passenv =
- *
+
+[testenv:check]
+deps =
+ docutils
+ check-manifest
+ flake8
+ readme-renderer
+ pygments
+ isort
+skip_install = true
+commands =
+ python setup.py check --strict --metadata --restructuredtext
+ check-manifest {toxinidir}
+ flake8 src tests setup.py
+ isort --verbose --check-only --diff --recursive src tests setup.py
[testenv:spell]
setenv =
@@ -60,21 +74,6 @@ commands =
sphinx-build {posargs:-E} -b html docs dist/docs
sphinx-build -b linkcheck docs dist/docs
-[testenv:check]
-deps =
- docutils
- check-manifest
- flake8
- readme-renderer
- pygments
- isort
-skip_install = true
-commands =
- python setup.py check --strict --metadata --restructuredtext
- check-manifest {toxinidir}
- flake8 src tests setup.py
- isort --verbose --check-only --diff --recursive src tests setup.py
-
[testenv:coveralls]
deps =
coveralls
@@ -90,12 +89,10 @@ commands =
coverage xml --ignore-errors
codecov []
-
[testenv:report]
deps = coverage
skip_install = true
commands =
- coverage combine --append
coverage report
coverage html
@@ -103,4 +100,3 @@ commands =
commands = coverage erase
skip_install = true
deps = coverage
-