summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Colangelo <warp10@ubuntu.com>2013-07-02 23:53:42 +0200
committerAndrea Colangelo <warp10@ubuntu.com>2013-07-02 23:53:42 +0200
commit418e57dd2f00732dc68237a8469d943ea03d0b39 (patch)
treeb443d577752d058d14938d0f5588ad39f32be1cb
parent912edf7d8564ae72961cf4f1d70340ef541c96f7 (diff)
python-tcpwrap (0.2-2.2) unstable; urgency=low
* Non-maintainer upload. * Convert to dh_python2. (Closes: #617034) [dgit import package python-tcpwrap 0.2-2.2]
-rw-r--r--debian/changelog36
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright17
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules72
7 files changed, 145 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..7b7639b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,36 @@
+python-tcpwrap (0.2-2.2) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Convert to dh_python2. (Closes: #617034)
+
+ -- Andrea Colangelo <warp10@ubuntu.com> Tue, 02 Jul 2013 23:53:42 +0200
+
+python-tcpwrap (0.2-2.1) unstable; urgency=low
+
+ * Convert to updated Python policy. Closes: #373359.
+
+ -- Matthias Klose <doko@debian.org> Tue, 11 Jul 2006 08:40:30 +0000
+
+python-tcpwrap (0.2-2) unstable; urgency=low
+
+ * Remove cruft from debian rules and get it to work building multiple
+ binary packages.
+ * Move to providing versioned python packages with a dummy package that
+ depends on the one for the default python version.
+ * Conform package descriptions more to lintian standards.
+
+ -- Brian Sutherland <jinty@web.de> Tue, 11 Jan 2005 14:21:45 +0100
+
+python-tcpwrap (0.2-1) unstable; urgency=low
+
+ * New upstream release
+ * Close ITP bug (closes: #274391)
+
+ -- Brian Sutherland <jinty@web.de> Wed, 29 Sep 2004 10:56:04 +0200
+
+python-tcpwrap (0.1-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Brian Sutherland <jinty@web.de> Mon, 27 Sep 2004 22:47:52 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c9bbe75
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: python-tcpwrap
+Section: python
+Priority: optional
+Maintainer: Brian Sutherland <jinty@web.de>
+Build-Depends: debhelper (>= 5.0.37.2), python-all-dev (>= 2.6.6-3~), libwrap0-dev
+Standards-Version: 3.6.1
+
+Package: python-tcpwrap
+Architecture: any
+Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Conflicts: python2.3-tcpwrap, python2.4-tcpwrap
+Replaces: python2.3-tcpwrap, python2.4-tcpwrap
+Provides: ${python:Provides}
+Description: python interface for libwrap0 (TCP wrappers)
+ libwrap0 is a library for TCP wrappers so that programs can support TCP
+ wrappers natively. This package provides a Python interface for libwrap0.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..35a73a8
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,17 @@
+Maintainers, past and present:
+------------------------------
+This package was debianized by Brian Sutherland <jinty@web.de> on
+Mon, 27 Sep 2004 22:47:52 +0200.
+
+Source:
+-------
+It was downloaded from http://ples.sourceforge.net/index.cgi?PyTCPWrap
+
+Upstream Author:
+----------------
+Eugene Coetzee <eugene@reedflute.com>
+
+Copyright:
+----------
+This software is licensed under the GNU Lesser Public License, which
+should be available in /usr/share/common-licenses/LGPL
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..74d3f23
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,72 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+PYVERS := $(shell pyversions -vr debian/control)
+
+build: build-arch
+
+build-arch: build-arch-stamp
+build-arch-stamp:
+ dh_testdir
+ set -e; \
+ for v in $(PYVERS); do \
+ /usr/bin/python$$v setup.py build; \
+ done
+ touch build-arch-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-arch-stamp
+ rm -rf build
+ dh_clean
+
+install-indep:
+ dh_testdir
+ dh_testroot
+ dh_clean -k -i
+ dh_installdirs -i
+
+install-arch: build-arch
+ dh_testdir
+ dh_testroot
+ dh_clean -k -s
+ dh_installdirs -s
+ set -e; \
+ for v in $(PYVERS); do \
+ /usr/bin/python$$v setup.py install \
+ --prefix=debian/python-tcpwrap/usr; \
+ done
+
+binary-common:
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs CHANGELOG
+ dh_installdocs
+ dh_installexamples
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_python2
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-indep: install-indep
+ $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
+
+binary-arch: build-arch install-arch
+ $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
+
+binary: binary-indep binary-arch
+
+.PHONY: build build-arch clean install-indep install-arch
+.PHONY: binary-common binary-indep binary-arch binary