summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorMichael Fladischer <FladischerMichael@fladi.at>2017-01-26 17:39:23 +0100
committerMichael Fladischer <FladischerMichael@fladi.at>2017-01-26 17:39:23 +0100
commitbdb10da94ce984ae8dd3926ee24f256b869e0b73 (patch)
tree1b1858b7759c5481b9dc1c6bec7a0f4e0280dfe3 /.travis.yml
importing python-testfixtures_4.13.3.orig.tar.gz
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml32
1 files changed, 32 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..ad19bfb
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,32 @@
+language: python
+
+# for container-y googdness:
+sudo: false
+
+python:
+ - "3.5"
+ - "3.4"
+ - "3.3"
+ - "2.7"
+
+# command to install dependencies
+install: "pip install -Ue .[test,build]"
+
+# command to run tests, e.g. python setup.py test
+script: nosetests --with-cov --cov=testfixtures
+
+after_success:
+ - coverage combine
+ - coveralls
+
+deploy:
+ provider: pypi
+ user: chrisw
+ password:
+ secure: QrmUWPegJzGIYGI8XGY7ztjHTbpMgVDLNV6f9fjjAoo8efOubJh/BASjWD3ESPlIo1j5tGCcSRP2MN1+30zBxq7a7oiCnthISx42DP6Ih+wLHFCu7uBm12AH96hIOQUAtQotNSwB9dJAJIKKom7xkrV/nStjbcqC7hosTZlTy6o=
+ on:
+ tags: true
+ repo: Simplistix/testfixtures
+ python: "3.4"
+ skip_cleanup: true
+ distributions: "sdist bdist_wheel"