summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2017-02-07 21:41:51 +0100
committerAndrew Shadura <andrewsh@debian.org>2017-02-07 21:41:51 +0100
commit35f29cba23fc56f87acaff1741ec8d921db0c59f (patch)
tree298703a4334eb61c2877f3285402eb68a2b8581f
Imported Upstream version 1.1.0
-rw-r--r--.gitignore7
-rw-r--r--.travis.yml15
-rw-r--r--LICENSE177
-rw-r--r--MANIFEST.in4
-rw-r--r--README.rst33
-rwxr-xr-xsetup.py49
-rw-r--r--test_unpaddedbase64.py41
-rw-r--r--tox.ini27
-rw-r--r--unpaddedbase64.py40
9 files changed, 393 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..25ccf99
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+.coverage
+.tox/
+__pycache__/
+unpaddedbase64.egg-info/
+unpaddedbase64.pyc
+build/
+dist/
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..b10c59a
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,15 @@
+language: python
+env:
+- TOXENV=packaging
+- TOXENV=pep8
+- TOXENV=py3pep8
+- TOXENV=py27
+- TOXENV=py33
+- TOXENV=py34
+- TOXENV=pypy
+
+install:
+- pip install tox
+
+script:
+- tox
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..f433b1a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,177 @@
+
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..6429bd5
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,4 @@
+include *.in
+include *.py
+include LICENSE
+include tox.ini
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..5796b7b
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,33 @@
+Unpadded Base64
+===============
+
+.. image:: https://img.shields.io/pypi/v/unpaddedbase64.svg
+ :target: https://pypi.python.org/pypi/unpaddedbase64/
+ :alt: Latest Version
+
+.. image:: https://img.shields.io/travis/matrix-org/python-unpaddedbase64.svg
+ :target: https://travis-ci.org/matrix-org/python-unpaddedbase64
+
+Encode and decode Base64 without "=" padding.
+
+`RFC 4648`_ specifies that Base64 should be padded to a multiple of 4 bytes
+using "=" characters. However this conveys no benefit so many protocols choose
+to use Base64 without the "=" padding.
+
+.. _`RFC 4648`: https://tools.ietf.org/html/rfc4648
+
+Installing
+----------
+
+.. code:: bash
+
+ pip install unpaddedbase64
+
+Using
+-----
+
+.. code:: python
+
+ import unpaddedbase64
+ assert (unpaddedbase64.encode_base64(b'\x00')) == u'AA'
+ assert (unpaddedbase64.decode_base64(u'AA')) == b'\x00'
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..6d7ee74
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,49 @@
+#!/usr/bin/env python
+
+# Copyright 2015 OpenMarket Ltd
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from setuptools import setup
+from codecs import open
+import os
+
+here = os.path.abspath(os.path.dirname(__file__))
+
+
+def read_file(path_segments):
+ """Read a UTF-8 file from the package. Takes a list of strings to join to
+ make the path"""
+ file_path = os.path.join(here, *path_segments)
+ with open(file_path, encoding="utf-8") as f:
+ return f.read()
+
+
+def exec_file(path_segments, name):
+ """Extract a constant from a python file by looking for a line defining
+ the constant and executing it."""
+ result = {}
+ code = read_file(path_segments)
+ lines = [line for line in code.split('\n') if line.startswith(name)]
+ exec("\n".join(lines), result)
+ return result[name]
+
+
+setup(
+ name="unpaddedbase64",
+ version=exec_file(("unpaddedbase64.py",), "__version__"),
+ py_modules=["unpaddedbase64"],
+ description="Unpadded Base64",
+ long_description=read_file(("README.rst",)),
+ keywords="base64",
+)
diff --git a/test_unpaddedbase64.py b/test_unpaddedbase64.py
new file mode 100644
index 0000000..a3c8463
--- /dev/null
+++ b/test_unpaddedbase64.py
@@ -0,0 +1,41 @@
+# Copyright 2015 OpenMarket Ltd
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from unpaddedbase64 import encode_base64, decode_base64
+import unittest
+
+
+class TestUnpaddedBase64(unittest.TestCase):
+
+ def test_encode(self):
+ self.assertEqual(encode_base64(b''), u'')
+ self.assertEqual(encode_base64(b'\x00'), u'AA')
+ self.assertEqual(encode_base64(b'\x00\x00'), u'AAA')
+ self.assertEqual(encode_base64(b'\x00\x00\x00'), u'AAAA')
+
+ def test_decode(self):
+ self.assertEqual(decode_base64(u''), b'')
+ self.assertEqual(decode_base64(u'AA'), b'\x00')
+ self.assertEqual(decode_base64(u'AAA'), b'\x00\x00')
+ self.assertEqual(decode_base64(u'AAAA'), b'\x00\x00\x00')
+ with self.assertRaises(Exception):
+ decode_base64(u'A')
+
+ def test_encode_urlunsafe_chars(self):
+ self.assertEqual(encode_base64(b'\xff\xe6\x9a'), u'/+aa')
+ self.assertEqual(encode_base64(b'\xff\xe6\x9a', True), u'_-aa')
+
+ def test_decode_urlunsafe_chars(self):
+ self.assertEqual(decode_base64(u'/+aa'), b'\xff\xe6\x9a')
+ self.assertEqual(decode_base64(u'_-aa'), b'\xff\xe6\x9a')
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..c368ee7
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,27 @@
+[tox]
+envlist = packaging, pep8, py3pep8, py27, py33, py34, pypy
+
+[testenv]
+deps =
+ coverage
+ pytest
+commands =
+ coverage run --source unpaddedbase64 -m pytest
+ coverage report -m --fail-under 100
+
+[testenv:packaging]
+deps =
+ check-manifest
+commands = check-manifest
+
+[testenv:pep8]
+basepython = python2.7
+deps =
+ flake8
+commands = flake8 .
+
+[testenv:py3pep8]
+basepython = python3.4
+deps =
+ flake8
+commands = flake8 .
diff --git a/unpaddedbase64.py b/unpaddedbase64.py
new file mode 100644
index 0000000..245697c
--- /dev/null
+++ b/unpaddedbase64.py
@@ -0,0 +1,40 @@
+# Copyright 2014, 2015 OpenMarket Ltd
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+import base64
+
+__version__ = "1.1.0"
+
+
+def encode_base64(input_bytes, urlsafe=False):
+ """Encode bytes as a base64 string without any padding."""
+
+ encode = base64.urlsafe_b64encode if urlsafe else base64.b64encode
+ output_bytes = encode(input_bytes)
+ output_string = output_bytes.decode("ascii")
+ return output_string.rstrip(u"=")
+
+
+def decode_base64(input_string):
+ """Decode a base64 string to bytes inferring padding from the length of the
+ string."""
+
+ input_bytes = input_string.encode("ascii")
+ input_len = len(input_bytes)
+ padding = b"=" * (3 - ((input_len + 3) % 4))
+ decode = base64.b64decode
+ if u'-' in input_string or u'_' in input_string:
+ decode = base64.urlsafe_b64decode
+ output_bytes = decode(input_bytes + padding)
+ return output_bytes