summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@debian.org>2016-09-04 16:52:49 +0000
committerJelmer Vernooij <jelmer@debian.org>2016-09-04 16:52:49 +0000
commit4d4e41ea28ad353ff3fc007138ca8dcce89687ba (patch)
tree08912316c92cf67acb297fac92d58054cda37387 /debian/patches
parentb3ce68a414b938b28304e43af729f66e11692550 (diff)
parentea94d325fb3093e0be21daa3ef7c25e638918c7a (diff)
Merge branch 'master' of git+ssh://git.debian.org/git/git/calendarserver/python-vobject
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/Don-t-install-ics_diff.patch (renamed from debian/patches/0001-don-t-install-ics_diff.patch)6
-rw-r--r--debian/patches/Treat-untils-as-floating.patch (renamed from debian/patches/0003-Treat-untils-as-floating.patch)4
-rw-r--r--debian/patches/series5
-rw-r--r--debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch53
4 files changed, 61 insertions, 7 deletions
diff --git a/debian/patches/0001-don-t-install-ics_diff.patch b/debian/patches/Don-t-install-ics_diff.patch
index 846e77f..3269c88 100644
--- a/debian/patches/0001-don-t-install-ics_diff.patch
+++ b/debian/patches/Don-t-install-ics_diff.patch
@@ -1,10 +1,10 @@
-From: =?UTF-8?q?Guido=20G=C3=BCnther?= <agx@sigxcpu.org>
+From: =?utf-8?q?Guido_G=C3=BCnther?= <agx@sigxcpu.org>
Date: Fri, 17 Apr 2009 22:46:06 +0200
Subject: don't install ics_diff
---
- setup.py | 2 --
- 1 files changed, 0 insertions(+), 2 deletions(-)
+ setup.py | 6 ------
+ 1 file changed, 6 deletions(-)
diff --git a/setup.py b/setup.py
index a99507b..1589ec5 100755
diff --git a/debian/patches/0003-Treat-untils-as-floating.patch b/debian/patches/Treat-untils-as-floating.patch
index e788401..f90ef96 100644
--- a/debian/patches/0003-Treat-untils-as-floating.patch
+++ b/debian/patches/Treat-untils-as-floating.patch
@@ -3,8 +3,8 @@ Date: Mon, 4 Jan 2010 20:27:01 +0100
Subject: Treat untils as floating
---
- vobject/icalendar.py | 14 +++++++++++++-
- 1 files changed, 13 insertions(+), 1 deletions(-)
+ vobject/icalendar.py | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
diff --git a/vobject/icalendar.py b/vobject/icalendar.py
index bfb00df..add91f7 100644
diff --git a/debian/patches/series b/debian/patches/series
index 3cfdb10..870c77a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
-0001-don-t-install-ics_diff.patch
-0003-Treat-untils-as-floating.patch
+Don-t-install-ics_diff.patch
+Treat-untils-as-floating.patch
+vcard-Fix-ORG-fields-with-multiple-components.patch
diff --git a/debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch b/debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch
new file mode 100644
index 0000000..befb779
--- /dev/null
+++ b/debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch
@@ -0,0 +1,53 @@
+From: Markus Unterwaditzer <markus@unterwaditzer.net>
+Date: Wed, 13 Apr 2016 22:43:39 +0200
+Subject: vcard: Fix ORG fields with multiple components
+
+---
+ test_files/simple_3_0_test.ics | 2 +-
+ tests.py | 7 ++++++-
+ vobject/vcard.py | 1 +
+ 3 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/test_files/simple_3_0_test.ics b/test_files/simple_3_0_test.ics
+index d5e4642..1faf80d 100644
+--- a/test_files/simple_3_0_test.ics
++++ b/test_files/simple_3_0_test.ics
+@@ -9,5 +9,5 @@ TEL;type=CELL:+01-(0)5-555.55.55
+ ACCOUNT;type=HOME:010-1234567-05
+ ADR;type=HOME:;;Haight Street 512\;\nEscape\, Test;Novosibirsk;;80214;Gnuland
+ TEL;type=HOME:+01-(0)2-876.54.32
+-ORG:University of Novosibirsk, Department of Octopus Parthenogenesis
++ORG:University of Novosibirsk;Department of Octopus Parthenogenesis
+ END:VCARD
+diff --git a/tests.py b/tests.py
+index 2073930..6b0fad9 100644
+--- a/tests.py
++++ b/tests.py
+@@ -516,9 +516,14 @@ class TestVcards(unittest.TestCase):
+ #)
+ self.assertEqual(
+ card.org.value,
+- "University of Novosibirsk, Department of Octopus Parthenogenesis"
++ ["University of Novosibirsk", "Department of Octopus Parthenogenesis"]
+ )
+
++ for _ in range(3):
++ new_card = base.readOne(card.serialize())
++ self.assertEqual(new_card.org.value, card.org.value)
++ card = new_card
++
+
+ class TestIcalendar(unittest.TestCase):
+ """
+diff --git a/vobject/vcard.py b/vobject/vcard.py
+index dd60b73..0aec844 100644
+--- a/vobject/vcard.py
++++ b/vobject/vcard.py
+@@ -338,6 +338,7 @@ class OrgBehavior(VCardBehavior):
+ if obj.isNative:
+ return obj
+ obj.isNative = True
++ obj.value = splitFields(obj.value)
+ return obj
+
+ @staticmethod