summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/control2
-rw-r--r--debian/patches/base.patch2
-rw-r--r--debian/patches/disable-ez_setup.diff15
-rw-r--r--debian/patches/icalendar.patch21
-rwxr-xr-xdebian/rules6
6 files changed, 25 insertions, 32 deletions
diff --git a/debian/changelog b/debian/changelog
index 7946c35..ae1cb33 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+python-vobject (0.0.svn155-1) unstable; urgency=low
+
+ * new upstream svn version
+ * update icalendar.patch and base.patch from revision 188 of:
+ http://trac.macosforge.org/projects/calendarserver/browser/CalendarServer/trunk/patches/vObject/base.patch
+ http://trac.macosforge.org/projects/calendarserver/browser/CalendarServer/trunk/patches/vObject/icalendar.patch
+ * call test during build
+ * add versione (>= 1.1) dependency for python-dateutil
+
+ -- Guido Guenther <agx@sigxcpu.org> Sat, 23 Sep 2006 23:57:41 +0200
+
python-vobject (0.0.svn147-2) unstable; urgency=low
* set pyversions
diff --git a/debian/control b/debian/control
index c3c69fc..3274765 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Standards-Version: 3.7.2
Package: python-vobject
Architecture: all
-Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, python-dateutil
+Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, python-dateutil (>= 1.1)
Description: parse iCalendar and VCards in python
Parses iCalendar and vCard files into Python data structures, decoding the
relevant encodings. Also serializes vobject data structures to valid iCalendar
diff --git a/debian/patches/base.patch b/debian/patches/base.patch
index cd3b4bf..72fbc47 100644
--- a/debian/patches/base.patch
+++ b/debian/patches/base.patch
@@ -1,6 +1,6 @@
Index: src/vobject/base.py
===================================================================
---- src/vobject/base.py (revision 147)
+--- src/vobject/base.py (revision 155)
+++ src/vobject/base.py (working copy)
@@ -1,5 +1,6 @@
"""vobject module for reading vCard and vCalendar files."""
diff --git a/debian/patches/disable-ez_setup.diff b/debian/patches/disable-ez_setup.diff
deleted file mode 100644
index 7349871..0000000
--- a/debian/patches/disable-ez_setup.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: python-vobject-154/setup.py
-===================================================================
---- python-vobject-154.orig/setup.py 2006-09-06 11:16:58.000000000 +0200
-+++ python-vobject-154/setup.py 2006-09-06 11:17:14.000000000 +0200
-@@ -6,10 +6,6 @@
- Requires dateutil (https://moin.conectiva.com.br/DateUtil) 0.9 or later.
- """
-
--# not using setuptools until Chandler's ready for eggs
--from ez_setup import use_setuptools
--use_setuptools()
--
- from setuptools import setup, find_packages
-
- #from distutils.core import setup
diff --git a/debian/patches/icalendar.patch b/debian/patches/icalendar.patch
index 92322f1..cdfde36 100644
--- a/debian/patches/icalendar.patch
+++ b/debian/patches/icalendar.patch
@@ -1,8 +1,8 @@
Index: src/vobject/icalendar.py
===================================================================
---- src/vobject/icalendar.py (revision 147)
+--- src/vobject/icalendar.py (revision 155)
+++ src/vobject/icalendar.py (working copy)
-@@ -374,8 +374,17 @@
+@@ -377,8 +377,17 @@
try:
dtstart = self.dtstart.value
except AttributeError, KeyError:
@@ -22,16 +22,7 @@ Index: src/vobject/icalendar.py
# rrulestr complains about unicode, so cast to str
rule = dateutil.rrule.rrulestr(str(line.value),
dtstart=dtstart)
-@@ -380,7 +389,7 @@
- rule = dateutil.rrule.rrulestr(str(line.value),
- dtstart=dtstart)
- until = rule._until
-- if until is not None and until.tzinfo != dtstart.tzinfo:
-+ if until is not None and isinstance(dtstart, datetime.datetime) and (until.tzinfo != dtstart.tzinfo):
- # dateutil converts the UNTIL date to a datetime,
- # check to see if the UNTIL parameter value was a date
- vals = dict(pair.split('=') for pair in
-@@ -417,7 +426,16 @@
+@@ -422,7 +431,16 @@
return rruleset
def setrruleset(self, rruleset):
@@ -49,7 +40,7 @@ Index: src/vobject/icalendar.py
isDate = datetime.date == type(dtstart)
if isDate:
dtstart = datetime.datetime(dtstart.year,dtstart.month, dtstart.day)
-@@ -573,6 +591,8 @@
+@@ -580,6 +598,8 @@
if obj.value.tzinfo is None:
obj.params['X-VOBJ-FLOATINGTIME-ALLOWED'] = ['TRUE']
if obj.params.get('TZID'):
@@ -58,7 +49,7 @@ Index: src/vobject/icalendar.py
del obj.params['TZID']
return obj
-@@ -585,6 +605,10 @@
+@@ -592,6 +612,10 @@
obj.value = dateTimeToString(obj.value, cls.forceUTC)
if not cls.forceUTC and tzid is not None:
obj.tzid_param = tzid
@@ -69,7 +60,7 @@ Index: src/vobject/icalendar.py
return obj
-@@ -605,7 +629,10 @@
+@@ -612,7 +636,10 @@
obj.value=str(obj.value)
obj.value=parseDtstart(obj)
if getattr(obj, 'value_param', 'DATE-TIME').upper() == 'DATE-TIME':
diff --git a/debian/rules b/debian/rules
index c2d9f6f..9a12298 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,3 +10,9 @@ DEB_PYTHON_CLEAN_ARGS = --all
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+
+build/python-vobject::
+ cd tests && PYTHONPATH=src python tests.py
+
+clean::
+ rm -rf src/vobject.egg-info/