summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py33
1 files changed, 20 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index bf3c141..1c70429 100755
--- a/setup.py
+++ b/setup.py
@@ -12,19 +12,25 @@ Requires python 2.4 or later, dateutil (http://labix.org/python-dateutil) 1.1 or
Recent changes
--------------
-
- * Allow unicode names for TZIDs
- * Worked around Lotus Notes use of underscores in names by just silently replacing
+ - Added change_tz module and script for quickly changing event timezones for an
+ ics file. Requires PyICU.
+ - Add support for BYMONTHDAY=-1 (days before the end of the month) when setting rrules
+ from a dateutil rrule
+ - Tolerate a Ruby iCalendar library escaping semi-colons in RRULEs
+ - Make vobjects pickle-able
+ - Add introspection help for IPython so tab completion works with
+ vobject's custom __getattr__
+ - Allow Outlook's technically illegal use of commas in TZIDs
+ - Allow unicode names for TZIDs
+ - Worked around Lotus Notes use of underscores in names by just silently replacing
with dashes
- * When allowing quoted-printable data, honor CHARSET for each line, defaulting to
+ - When allowing quoted-printable data, honor CHARSET for each line, defaulting to
iso-8859-1
- * Simplified directory layout, unit tests are now available via setup.py test
- * Added VAVAILABILITY support
- * Improved wrapping of unicode lines, serialize encodes unicode as utf-8 by default
+ - Simplified directory layout, unit tests are now available via setup.py test
-For older changes, see
- * http://vobject.skyhouseconsulting.com/history.html or
- * http://websvn.osafoundation.org/listing.php?repname=vobject&path=/trunk/
+For older changes, see
+ - http://vobject.skyhouseconsulting.com/history.html or
+ - http://websvn.osafoundation.org/listing.php?repname=vobject&path=/trunk/
"""
@@ -36,13 +42,14 @@ from setuptools import setup, find_packages
doclines = __doc__.splitlines()
setup(name = "vobject",
- version = "0.6.6",
+ version = "0.7.1",
author = "Jeffrey Harris",
author_email = "jeffrey@osafoundation.org",
license = "Apache",
zip_safe = True,
url = "http://vobject.skyhouseconsulting.com",
- entry_points = { 'console_scripts': ['ics_diff = vobject.ics_diff:main'] },
+ entry_points = { 'console_scripts': ['ics_diff = vobject.ics_diff:main',
+ 'change_tz = vobject.change_tz:main']},
include_package_data = True,
test_suite = "test_vobject",
@@ -53,7 +60,7 @@ setup(name = "vobject",
description = doclines[0],
long_description = "\n".join(doclines[2:]),
classifiers = """
- Development Status :: 4 - Beta
+ Development Status :: 5 - Production/Stable
Environment :: Console
License :: OSI Approved :: BSD License
Intended Audience :: Developers