summaryrefslogtreecommitdiff
path: root/debian/python2_old/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'debian/python2_old/setup.py')
-rwxr-xr-xdebian/python2_old/setup.py66
1 files changed, 66 insertions, 0 deletions
diff --git a/debian/python2_old/setup.py b/debian/python2_old/setup.py
new file mode 100755
index 0000000..ef68c33
--- /dev/null
+++ b/debian/python2_old/setup.py
@@ -0,0 +1,66 @@
+#!/usr/bin/env python
+from __future__ import absolute_import, division, print_function
+
+from io import open
+
+from os.path import abspath, dirname, join
+
+from setuptools import setup
+
+PROJECT_ROOT = abspath(dirname(__file__))
+with open(join(PROJECT_ROOT, 'README.rst'), encoding='utf-8') as f:
+ readme = f.read()
+
+version = (
+ [l for l in open(join(PROJECT_ROOT, 'zeroconf.py')) if '__version__' in l][0]
+ .split('=')[-1]
+ .strip().strip('\'"')
+)
+
+setup(
+ name='zeroconf',
+ version=version,
+ description='Pure Python Multicast DNS Service Discovery Library '
+ '(Bonjour/Avahi compatible)',
+ long_description=readme,
+ author='Paul Scott-Murphy, William McBrine, Jakub Stasiak',
+ url='https://github.com/jstasiak/python-zeroconf',
+ py_modules=['zeroconf'],
+ platforms=['unix', 'linux', 'osx'],
+ license='LGPL',
+ zip_safe=False,
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU Lesser General Public License v2 (LGPLv2)',
+ 'Operating System :: POSIX',
+ 'Operating System :: POSIX :: Linux',
+ 'Operating System :: MacOS :: MacOS X',
+ 'Topic :: Software Development :: Libraries',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ ],
+ keywords=[
+ 'Bonjour', 'Avahi', 'Zeroconf', 'Multicast DNS', 'Service Discovery',
+ 'mDNS',
+ ],
+ install_requires=[
+ 'enum34',
+ # netifaces 0.10.5 has a bug that results in all interfaces' netmasks
+ # to be 255.255.255.255 on Windows which breaks things. See:
+ # * https://github.com/jstasiak/python-zeroconf/issues/84
+ # * https://bitbucket.org/al45tair/netifaces/issues/39/netmask-is-always-255255255255
+ 'netifaces!=0.10.5',
+ 'six',
+ ],
+)