summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHernan Grecco <hernan.grecco@gmail.com>2014-02-08 19:30:45 -0300
committerHernan Grecco <hernan.grecco@gmail.com>2014-02-08 19:30:45 -0300
commitf10f947b1ef03c70c5177d395bc2dc64d2edc58d (patch)
tree7ddbef17747eed36fdcd705fc2017244082da043
parentad80e4ac1d819fe0ba7a0db7fc7153bdd9856121 (diff)
Improved doc appeareance
-rw-r--r--docs/Makefile8
-rw-r--r--docs/_templates/sidebarintro.html2
-rw-r--r--docs/_templates/sidebarlogo.html2
-rw-r--r--docs/_themes/sphinx_rtd_theme/layout.html19
-rw-r--r--docs/conf.py19
5 files changed, 9 insertions, 41 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 80fe3d3..866ca77 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -77,17 +77,17 @@ qthelp:
@echo
@echo "Build finished; now you can run "qcollectiongenerator" with the" \
".qhcp project file in $(BUILDDIR)/qthelp, like this:"
- @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/pint.qhcp"
+ @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/pyvisa.qhcp"
@echo "To view the help file:"
- @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/pint.qhc"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/pyvisa.qhc"
devhelp:
$(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
@echo
@echo "Build finished."
@echo "To view the help file:"
- @echo "# mkdir -p $$HOME/.local/share/devhelp/pint"
- @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/pint"
+ @echo "# mkdir -p $$HOME/.local/share/devhelp/pyvisa"
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/pyvisa"
@echo "# devhelp"
epub:
diff --git a/docs/_templates/sidebarintro.html b/docs/_templates/sidebarintro.html
index 3a1d83b..92ebbc4 100644
--- a/docs/_templates/sidebarintro.html
+++ b/docs/_templates/sidebarintro.html
@@ -12,7 +12,7 @@ You are currently looking at the documentation of version {{ version }}.
</ul>
<h3>Useful Links</h3>
<ul>
- <li><a href="https://pypi.python.org/pypi/pyvisa/">Pint @ PyPI</a></li>
+ <li><a href="https://pypi.python.org/pypi/pyvisa/">PyVISA @ PyPI</a></li>
<li><a href="https://github.com/hgrecco/pyvisa">Code in GitHub</a></li>
<li><a href="https://github.com/hgrecco/pyvisa/issues">Issue Tracker</a></li>
</ul>
diff --git a/docs/_templates/sidebarlogo.html b/docs/_templates/sidebarlogo.html
index 1c74be0..f220931 100644
--- a/docs/_templates/sidebarlogo.html
+++ b/docs/_templates/sidebarlogo.html
@@ -16,7 +16,7 @@ You are currently looking at the documentation of version {{ version }}.
</ul>
<h3>Useful Links</h3>
<ul>
- <li><a href="https://pypi.python.org/pypi/pyvisa/">Pint @ PyPI</a></li>
+ <li><a href="https://pypi.python.org/pypi/pyvisa/">PyVISA @ PyPI</a></li>
<li><a href="https://github.com/hgrecco/pyvisa">Code in GitHub</a></li>
<li><a href="https://github.com/hgrecco/pyvisa/issues">Issue Tracker</a></li>
</ul>
diff --git a/docs/_themes/sphinx_rtd_theme/layout.html b/docs/_themes/sphinx_rtd_theme/layout.html
index abc48e1..552c77f 100644
--- a/docs/_themes/sphinx_rtd_theme/layout.html
+++ b/docs/_themes/sphinx_rtd_theme/layout.html
@@ -110,28 +110,11 @@
<div>
Python wrapper for the Virtual Instrument Software Architechture library.
You are currently looking at the documentation of version {{ version }}.
+ <p></p>
</div>
{% include "searchbox.html" %}
</div>
- <div class="">
- <h3>Other Formats</h3>
- <p>
- You can download the documentation in other formats as well:
- </p>
- <ul>
- <li><a href="https://media.readthedocs.org/pdf/pyvisa/latest/pyvisa.pdf">as PDF</a>
- <li><a href="https://media.readthedocs.org/htmlzip/pyvisa/latest/pyvisa.zip">as ePub</a>
- <li><a href="https://media.readthedocs.org/epub/pyvisa/latest/pyvisa.epub">as zipped HTML</a>
- </ul>
- <h3>Useful Links</h3>
- <ul>
- <li><a href="https://pypi.python.org/pypi/pyvisa/">PyVISA @ PyPI</a></li>
- <li><a href="https://github.com/hgrecco/pyvisa">Code in GitHub</a></li>
- <li><a href="https://github.com/hgrecco/pyvisa/issues">Issue Tracker</a></li>
- </ul>
- </div>
-
<div class="wy-menu wy-menu-vertical" data-spy="affix" role="navigation" aria-label="main navigation">
{% set toctree = toctree(maxdepth=2, collapse=False, includehidden=True) %}
{% if toctree %}
diff --git a/docs/conf.py b/docs/conf.py
index 837f3d5..7f5517d 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -48,25 +48,10 @@ author = 'PyVISA Authors'
# |version| and |release|, also used in various other places throughout the
# built documents.
-__version__ = "unknown"
-try:
- # try to grab the commit version of our package
- __version__ = (subprocess.check_output(["git", "describe"],
- cwd=os.path.dirname(os.path.abspath(__file__)))).strip()
-except:
- # on any error just try to grab the version that is installed on the system
- try:
- __version__ = pkg_resources.get_distribution(project).version
- except:
- # we seem to have a local copy without any repository control
- # or installed without setuptools
- # so the reported version will be __unknown__
- pass
-
-version = __version__
+version = pkg_resources.get_distribution(project).version
release = version
this_year = datetime.date.today().year
-#copyright = '%s, %s' % (this_year, author)
+copyright = '%s, %s' % (this_year, author)
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.