summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-19 22:12:30 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-19 22:12:30 +0200
commit9c5924b696b7c9fa626464a294c5c235ed166bf8 (patch)
treed84d390f71a9ebacf7e300838c535bcfb26e9ecc /setup.py
parent482f79d72e2e19442e33bc9db5b7b8b10661381e (diff)
New upstream version 1.9.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 5 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index a3d05a8..2086c01 100644
--- a/setup.py
+++ b/setup.py
@@ -1,12 +1,7 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-try:
- import sys
- reload(sys).setdefaultencoding("UTF-8")
-except:
- pass
-
+import sys
try:
from setuptools import setup
@@ -16,8 +11,8 @@ except ImportError:
def read(filename):
- with open(filename, 'r') as f:
- return f.read()
+ with open(filename, 'rb') as f:
+ return f.read().decode('utf8')
long_description = '\n\n'.join([read('README'),
@@ -27,12 +22,12 @@ long_description = '\n\n'.join([read('README'),
__doc__ = long_description
requirements = []
-if sys.version_info < (3, 4):
+if sys.version_info < (3,):
requirements.append('enum34')
setup(name='PyVISA',
description='Python VISA bindings for GPIB, RS232, TCPIP and USB instruments',
- version='1.9.0',
+ version='1.9.1',
long_description=long_description,
author='Torsten Bronger, Gregor Thalhammer',
author_email='bronger@physik.rwth-aachen.de',