summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDebian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>2023-12-14 19:06:53 +0100
committerÉtienne Mollier <emollier@debian.org>2023-12-14 19:06:53 +0100
commitc4c820aa9ace8652b206d404ff3000eafa65ac28 (patch)
treebf1f755b0e30191186a7ad622df67553503b9227
parente537cf2e7c27dcfca4c3915a0d10aaaaafbf5329 (diff)
python2 to python3 patch
Forwarded: yes =================================================================== Gbp-Pq: Name py2to3test.patch
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 94bf97a..ae37ebb 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
.PHONY: all lint test test-cov install dev clean distclean
-PYTHON ?= python
+PYTHON ?= python3
+DESTDIR ?= $(CURDIR)/debian/q2-sample-classifier/
all: ;
@@ -9,13 +10,13 @@ lint:
flake8
test: all
- py.test
+ py.test-3
test-cov: all
- py.test --cov=q2_sample_classifier
+ py.test-3 --cov=q2_sample_classifier
install:
- $(PYTHON) setup.py install
+ $(PYTHON) setup.py install --root $(DESTDIR) --prefix=/usr --install-platlib=/usr/lib/python3/dist-packages
dev: all
pip install -e .