summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorTim Edwards <tim@opencircuitdesign.com>2015-06-03 17:33:08 -0400
committerTim Edwards <tim@opencircuitdesign.com>2015-06-03 17:33:08 -0400
commit19915e5e41e28af0d618cc1acf7226da12214e0d (patch)
tree630f1be86a21da3f86555f829c6717e80013379b /scripts
parent6d0fd58e4c1ccb39972f0b63ceb0f638c9b79fed (diff)
Modified scripts such that all TCL scripts are annotated with the
correct path to "tclsh" on installation.
Diffstat (limited to 'scripts')
-rw-r--r--scripts/Makefile55
-rw-r--r--scripts/Makefile.in53
-rwxr-xr-xscripts/addspacers.tcl.in (renamed from scripts/addspacers.tcl)2
-rwxr-xr-xscripts/blif2cel.tcl.in (renamed from scripts/blif2cel.tcl)2
-rwxr-xr-xscripts/blif2sim.tcl.in (renamed from scripts/blif2sim.tcl)2
-rwxr-xr-xscripts/blifanno.tcl.in (renamed from scripts/blifanno.tcl)2
-rwxr-xr-xscripts/decongest.tcl.in (renamed from scripts/decongest.tcl)2
-rwxr-xr-xscripts/getfillcell.tcl.in (renamed from scripts/getfillcell.tcl)2
-rwxr-xr-xscripts/place2def.tcl.in (renamed from scripts/place2def.tcl)2
-rwxr-xr-xscripts/place2def2.tcl.in (renamed from scripts/place2def2.tcl)2
-rwxr-xr-xscripts/place2lef2.tcl.in (renamed from scripts/place2lef2.tcl)1
-rwxr-xr-xscripts/place2net2.tcl.in (renamed from scripts/place2net2.tcl)2
-rwxr-xr-xscripts/rtl2sim.tcl.in (renamed from scripts/rtl2sim.tcl)2
-rwxr-xr-xscripts/ybuffer.tcl.in (renamed from scripts/ybuffer.tcl)2
-rwxr-xr-xscripts/ypostproc.tcl.in (renamed from scripts/ypostproc.tcl)2
15 files changed, 98 insertions, 35 deletions
diff --git a/scripts/Makefile b/scripts/Makefile
index ae68721..61357cd 100644
--- a/scripts/Makefile
+++ b/scripts/Makefile
@@ -4,7 +4,7 @@
# Main compiler arguments
CFLAGS = -g -O2
-DEFS = -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1 -DHAVE_SETENV=1 -DHAVE_PUTENV=1 -DTCLSH_PATH=\"tclsh\" -DQFLOW_MAGIC_PATH=\"/usr/local/bin/magic\" -DQFLOW_QROUTER_PATH=\"/usr/local/bin/qrouter\" -DQFLOW_GRAYWOLF_PATH=\"/usr/local/bin/graywolf\" -DQFLOW_YOSYS_PATH=\"/usr/local/bin/yosys\"
+DEFS = -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1 -DHAVE_SETENV=1 -DHAVE_PUTENV=1 -DTCLSH_PATH=\"/bin/tclsh\" -DQFLOW_MAGIC_PATH=\"/usr/local/bin/magic\" -DQFLOW_QROUTER_PATH=\"/usr/local/bin/qrouter\" -DQFLOW_GRAYWOLF_PATH=\"/usr/local/bin/graywolf\" -DQFLOW_YOSYS_PATH=\"/usr/local/bin/yosys\"
LIBS =
LDFLAGS =
INSTALL = /bin/install -c
@@ -13,6 +13,7 @@ VERSION = 1.1
QFLOW_LIB_DIR = /usr/local/share/qflow
QFLOW_BIN_DIR = /usr/local/bin
+TCLSH_PATH = /bin/tclsh
DEFAULTPARSER = @QFLOW_DEFAULT_PARSER@
@@ -34,20 +35,50 @@ all: $(MAIN_SCRIPT).in qflow.sh
$(MAKE) launcher
launcher: $(MAIN_SCRIPT).in
- sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
- $(MAIN_SCRIPT).in > $(MAIN_SCRIPT)
+ sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
+ $(MAIN_SCRIPT).in > $(MAIN_SCRIPT)
checkdirs.sh: checkdirs.sh.in
- sed -e '/SUBST_TECH_DIR/s#SUBST_TECH_DIR#$(TECHINSTALL)#' \
- -e '/SUBST_SCRIPT_DIR/s#SUBST_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
- -e '/SUBST_BIN_DIR/s#SUBST_BIN_DIR#$(QFLOWEXECPATH)#' \
- checkdirs.sh.in > checkdirs.sh
+ sed -e '/SUBST_TECH_DIR/s#SUBST_TECH_DIR#$(TECHINSTALL)#' \
+ -e '/SUBST_SCRIPT_DIR/s#SUBST_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
+ -e '/SUBST_BIN_DIR/s#SUBST_BIN_DIR#$(QFLOWEXECPATH)#' \
+ checkdirs.sh.in > checkdirs.sh
qflow.sh: qflow.sh.in
- sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
- -e '/QFLOW_DEFAULT_PARSER/s#QFLOW_DEFAULT_PARSER#$(DEFAULTPARSER)#' \
- -e '/QFLOW_VERSION/s#QFLOW_VERSION#$(VERSION)#' \
- qflow.sh.in > qflow.sh
+ sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
+ -e '/QFLOW_DEFAULT_PARSER/s#QFLOW_DEFAULT_PARSER#$(DEFAULTPARSER)#' \
+ -e '/QFLOW_VERSION/s#QFLOW_VERSION#$(VERSION)#' \
+ qflow.sh.in > qflow.sh
+
+blif2cel.tcl: blif2cel.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' blif2cel.tcl.in > $@
+
+place2def.tcl: place2def.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' place2def.tcl.in > $@
+
+place2lef2.tcl: place2def2.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' place2lef2.tcl.in > $@
+
+place2net2.tcl: place2net2.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' place2net2.tcl.in > $@
+
+ypostproc.tcl: ypostproc.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' ypostproc.tcl.in > $@
+
+ybuffer.tcl: ybuffer.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' ybuffer.tcl.in > $@
+
+decongest.tcl: decongest.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' decongest.tcl.in > $@
+
+addspacers.tcl: addspacers.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' addspacers.tcl.in > $@
+
+getfillcell.tcl: getfillcell.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' getfillcell.tcl.in > $@
+
+blifanno.tcl: blifanno.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' blifanno.tcl.in > $@
install: $(TCL_SCRIPTS) $(SHELL_SCRIPTS) $(MAIN_SCRIPT)
@echo "Installing qflow scripts"
@@ -66,8 +97,8 @@ clean:
$(RM) $(MAIN_SCRIPT)
$(RM) checkdirs.sh
$(RM) qflow.sh
+ $(RM) $(TCL_SCRIPTS)
uninstall:
$(RM) -rf ${SCRIPTINSTALL}
$(RM) ${EXECINSTALL}/${MAIN_SCRIPT}
-
diff --git a/scripts/Makefile.in b/scripts/Makefile.in
index 119675f..9df7062 100644
--- a/scripts/Makefile.in
+++ b/scripts/Makefile.in
@@ -13,6 +13,7 @@ VERSION = @VERSION@
QFLOW_LIB_DIR = @QFLOW_LIB_DIR@
QFLOW_BIN_DIR = @QFLOW_BIN_DIR@
+TCLSH_PATH = @TCLSH_PATH@
DEFAULTPARSER = @QFLOW_DEFAULT_PARSER@
@@ -34,20 +35,50 @@ all: $(MAIN_SCRIPT).in qflow.sh
$(MAKE) launcher
launcher: $(MAIN_SCRIPT).in
- sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
- $(MAIN_SCRIPT).in > $(MAIN_SCRIPT)
+ sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
+ $(MAIN_SCRIPT).in > $(MAIN_SCRIPT)
checkdirs.sh: checkdirs.sh.in
- sed -e '/SUBST_TECH_DIR/s#SUBST_TECH_DIR#$(TECHINSTALL)#' \
- -e '/SUBST_SCRIPT_DIR/s#SUBST_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
- -e '/SUBST_BIN_DIR/s#SUBST_BIN_DIR#$(QFLOWEXECPATH)#' \
- checkdirs.sh.in > checkdirs.sh
+ sed -e '/SUBST_TECH_DIR/s#SUBST_TECH_DIR#$(TECHINSTALL)#' \
+ -e '/SUBST_SCRIPT_DIR/s#SUBST_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
+ -e '/SUBST_BIN_DIR/s#SUBST_BIN_DIR#$(QFLOWEXECPATH)#' \
+ checkdirs.sh.in > checkdirs.sh
qflow.sh: qflow.sh.in
- sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
- -e '/QFLOW_DEFAULT_PARSER/s#QFLOW_DEFAULT_PARSER#$(DEFAULTPARSER)#' \
- -e '/QFLOW_VERSION/s#QFLOW_VERSION#$(VERSION)#' \
- qflow.sh.in > qflow.sh
+ sed -e '/QFLOW_SCRIPT_DIR/s#QFLOW_SCRIPT_DIR#$(SCRIPTINSTALL)#' \
+ -e '/QFLOW_DEFAULT_PARSER/s#QFLOW_DEFAULT_PARSER#$(DEFAULTPARSER)#' \
+ -e '/QFLOW_VERSION/s#QFLOW_VERSION#$(VERSION)#' \
+ qflow.sh.in > qflow.sh
+
+blif2cel.tcl: blif2cel.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' blif2cel.tcl.in > $@
+
+place2def.tcl: place2def.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' place2def.tcl.in > $@
+
+place2lef2.tcl: place2def2.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' place2lef2.tcl.in > $@
+
+place2net2.tcl: place2net2.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' place2net2.tcl.in > $@
+
+ypostproc.tcl: ypostproc.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' ypostproc.tcl.in > $@
+
+ybuffer.tcl: ybuffer.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' ybuffer.tcl.in > $@
+
+decongest.tcl: decongest.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' decongest.tcl.in > $@
+
+addspacers.tcl: addspacers.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' addspacers.tcl.in > $@
+
+getfillcell.tcl: getfillcell.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' getfillcell.tcl.in > $@
+
+blifanno.tcl: blifanno.tcl.in
+ sed -e 's#TCLSH_PATH#$(TCLSH_PATH)#' blifanno.tcl.in > $@
install: $(TCL_SCRIPTS) $(SHELL_SCRIPTS) $(MAIN_SCRIPT)
@echo "Installing qflow scripts"
@@ -66,8 +97,8 @@ clean:
$(RM) $(MAIN_SCRIPT)
$(RM) checkdirs.sh
$(RM) qflow.sh
+ $(RM) $(TCL_SCRIPTS)
uninstall:
$(RM) -rf ${SCRIPTINSTALL}
$(RM) ${EXECINSTALL}/${MAIN_SCRIPT}
-
diff --git a/scripts/addspacers.tcl b/scripts/addspacers.tcl.in
index f0bbfbf..9d535ed 100755
--- a/scripts/addspacers.tcl
+++ b/scripts/addspacers.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#---------------------------------------------------------------------------
# addspacers.tcl ---
#
diff --git a/scripts/blif2cel.tcl b/scripts/blif2cel.tcl.in
index 5c4bd64..32a059f 100755
--- a/scripts/blif2cel.tcl
+++ b/scripts/blif2cel.tcl.in
@@ -1,4 +1,4 @@
-#!/usr/bin/tclsh
+#!TCLSH_PATH
#
# Usage:
# blif2cel.tcl <blif_filename> <lef_filename> [<cel_filename>]
diff --git a/scripts/blif2sim.tcl b/scripts/blif2sim.tcl.in
index 8355934..f320ffa 100755
--- a/scripts/blif2sim.tcl
+++ b/scripts/blif2sim.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#
# Usage:
# blif2sim.tcl <blif_filename> <dir> [<sim_filename>]
diff --git a/scripts/blifanno.tcl b/scripts/blifanno.tcl.in
index 6f29ab9..63c6bad 100755
--- a/scripts/blifanno.tcl
+++ b/scripts/blifanno.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#---------------------------------------------------------------------------
# blifanno.tcl ---
#
diff --git a/scripts/decongest.tcl b/scripts/decongest.tcl.in
index 5c34750..e9c0098 100755
--- a/scripts/decongest.tcl
+++ b/scripts/decongest.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#
# Usage:
# decongest.tcl <rootname> <leffile> <fillcell> [<scale> <offset>]
diff --git a/scripts/getfillcell.tcl b/scripts/getfillcell.tcl.in
index fd86471..ff5fe1c 100755
--- a/scripts/getfillcell.tcl
+++ b/scripts/getfillcell.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#---------------------------------------------------------------------------
# getfillcell.tcl ---
#
diff --git a/scripts/place2def.tcl b/scripts/place2def.tcl.in
index d42cc7e..eb07f50 100755
--- a/scripts/place2def.tcl
+++ b/scripts/place2def.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#---------------------------------------------------------------------------
# place2def.tcl ---
#
diff --git a/scripts/place2def2.tcl b/scripts/place2def2.tcl.in
index 1e8e5f3..dfa11f2 100755
--- a/scripts/place2def2.tcl
+++ b/scripts/place2def2.tcl.in
@@ -1,4 +1,4 @@
-#!/usr/bin/tclsh
+#!TCLSH_PATH
#---------------------------------------------------------------------------
# place2def2.tcl <rootname> <lefname> ---
#
diff --git a/scripts/place2lef2.tcl b/scripts/place2lef2.tcl.in
index b65f9fd..2d42186 100755
--- a/scripts/place2lef2.tcl
+++ b/scripts/place2lef2.tcl.in
@@ -1,3 +1,4 @@
+#!TCLSH_PATH
#---------------------------------------------------------------------------
# place2lef2.tcl ---
#
diff --git a/scripts/place2net2.tcl b/scripts/place2net2.tcl.in
index 78fe0ae..b9ac01d 100755
--- a/scripts/place2net2.tcl
+++ b/scripts/place2net2.tcl.in
@@ -1,4 +1,4 @@
-#!/usr/bin/tclsh
+#!TCLSH_PATH
#---------------------------------------------------------------------------
# place2net2.tcl ---
#
diff --git a/scripts/rtl2sim.tcl b/scripts/rtl2sim.tcl.in
index 419d555..c1fa5b1 100755
--- a/scripts/rtl2sim.tcl
+++ b/scripts/rtl2sim.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#
# Usage:
# rtl2sim.tcl <verilog_rtl_filename> <dir> [<sim_filename>]
diff --git a/scripts/ybuffer.tcl b/scripts/ybuffer.tcl.in
index b323ed5..05b45a4 100755
--- a/scripts/ybuffer.tcl
+++ b/scripts/ybuffer.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#-------------------------------------------------------------------------
# ybuffer --- post-process a mapped .blif file generated by yosys
#
diff --git a/scripts/ypostproc.tcl b/scripts/ypostproc.tcl.in
index 0380fbc..6d817ad 100755
--- a/scripts/ypostproc.tcl
+++ b/scripts/ypostproc.tcl.in
@@ -1,4 +1,4 @@
-#!/bin/tclsh
+#!TCLSH_PATH
#-------------------------------------------------------------------------
# ypostproc --- post-process a mapped .blif file generated by yosys
#