summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorTim Edwards <tim@opencircuitdesign.com>2016-01-09 10:43:45 -0500
committerTim Edwards <tim@opencircuitdesign.com>2016-01-09 10:43:45 -0500
commit3921043f07f62e6b9b3b3d96630f51174fdfc8fb (patch)
tree6f14be497eb9c32c48b86a41e83b676e36c15a88 /scripts
parente4634a121fb8dbfd44d24b11ccad7d6e2124a917 (diff)
Corrected installation and execution for local installations of
yosys. Specifically, yosys calls yosys-abc, which if not in the standard search path, must be specified using the "-exe" switch to the "abc" command in yosys.
Diffstat (limited to 'scripts')
-rw-r--r--scripts/Makefile2
-rwxr-xr-xscripts/router.sh6
-rwxr-xr-xscripts/synthesize.sh6
3 files changed, 8 insertions, 6 deletions
diff --git a/scripts/Makefile b/scripts/Makefile
index 390ca04..0b3c915 100644
--- a/scripts/Makefile
+++ b/scripts/Makefile
@@ -10,7 +10,7 @@ LDFLAGS =
INSTALL = /bin/install -c
VERSION = 1.1
-REVISION = 14
+REVISION = 22
QFLOW_LIB_DIR = /usr/local/share/qflow
QFLOW_BIN_DIR = /usr/local/bin
diff --git a/scripts/router.sh b/scripts/router.sh
index cfb3556..37a5c5e 100755
--- a/scripts/router.sh
+++ b/scripts/router.sh
@@ -153,8 +153,10 @@ if (${scripting} == "T") then
endif
endif
-rm ${rootname}.def
-mv ${rootname}_route.def ${rootname}.def
+if ( -f ${rootname}_route.def ) then
+ rm -f ${rootname}.def
+ mv ${rootname}_route.def ${rootname}.def
+endif
#------------------------------------------------------------
# Done!
diff --git a/scripts/synthesize.sh b/scripts/synthesize.sh
index 571962a..ba52079 100755
--- a/scripts/synthesize.sh
+++ b/scripts/synthesize.sh
@@ -258,7 +258,7 @@ EOF
if ( ${?abc_script} ) then
if ( ${abc_script} != "" ) then
cat >> ${rootname}.ys << EOF
-abc -liberty ${libertypath} -script ${abc_script}
+abc -exe ${bindir}/yosys-abc -liberty ${libertypath} -script ${abc_script}
flatten
EOF
@@ -266,7 +266,7 @@ EOF
echo "Warning: no abc script ${abc_script}, using default, no script" \
|& tee -a ${synthlog}
cat >> ${rootname}.ys << EOF
-abc -liberty ${libertypath}
+abc -exe ${bindir}/yosys-abc -liberty ${libertypath}
flatten
EOF
@@ -274,7 +274,7 @@ EOF
else
cat >> ${rootname}.ys << EOF
# Map combinatorial cells, standard script
-abc -liberty ${libertypath} -script +strash;scorr;ifraig;retime,{D};strash;dch,-f;map,-M,1,{D}
+abc -exe ${bindir}/yosys-abc -liberty ${libertypath} -script +strash;scorr;ifraig;retime,{D};strash;dch,-f;map,-M,1,{D}
flatten
EOF