summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorTim Edwards <tim@opencircuitdesign.com>2016-01-09 10:43:45 -0500
committerTim Edwards <tim@opencircuitdesign.com>2016-01-09 10:43:45 -0500
commit3921043f07f62e6b9b3b3d96630f51174fdfc8fb (patch)
tree6f14be497eb9c32c48b86a41e83b676e36c15a88 /src
parente4634a121fb8dbfd44d24b11ccad7d6e2124a917 (diff)
Corrected installation and execution for local installations of
yosys. Specifically, yosys calls yosys-abc, which if not in the standard search path, must be specified using the "-exe" switch to the "abc" command in yosys.
Diffstat (limited to 'src')
-rw-r--r--src/Makefile1
-rw-r--r--src/Makefile.in1
2 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
index 63bdb06..624122e 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -59,6 +59,7 @@ install: $(TARGETS)
(cd $(DESTDIR)${BININSTALL}; $(RM) -f magic; ln -s $(QFLOW_MAGIC_PATH) magic)
@if test "${HAVE_YOSYS}" = "1"; then \
(cd $(DESTDIR)${BININSTALL}; $(RM) -f yosys; ln -s $(QFLOW_YOSYS_PATH) yosys); \
+ (cd $(DESTDIR)${BININSTALL}; $(RM) -f yosys-abc; ln -s $(QFLOW_YOSYS_PATH)-abc yosys-abc); \
fi
uninstall:
diff --git a/src/Makefile.in b/src/Makefile.in
index 09e164d..03bc2fd 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -59,6 +59,7 @@ install: $(TARGETS)
(cd $(DESTDIR)${BININSTALL}; $(RM) -f magic; ln -s $(QFLOW_MAGIC_PATH) magic)
@if test "${HAVE_YOSYS}" = "1"; then \
(cd $(DESTDIR)${BININSTALL}; $(RM) -f yosys; ln -s $(QFLOW_YOSYS_PATH) yosys); \
+ (cd $(DESTDIR)${BININSTALL}; $(RM) -f yosys-abc; ln -s $(QFLOW_YOSYS_PATH)-abc yosys-abc); \
fi
uninstall: