summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTim Edwards <tim@opencircuitdesign.com>2014-10-11 10:38:58 -0400
committerTim Edwards <tim@opencircuitdesign.com>2014-10-11 10:38:58 -0400
commit2f23c720c67b145b78a0cbc3ecc0aab701281065 (patch)
treec9dfc7820bfb71aa8a3f09319a143f21a55d8c5f /Makefile
parentebb1ab8094235ecb1734f21cceaf973739e4094d (diff)
Applied patches from Ruben Undheim. Corrects compile and install
problems on systems requiring -fPIC on all source compiles. Fixed an error preventing Tcl/Tk from finding the "lowerconsole" procedure, and changed console.tcl so that exiting the console exits the program, which is correct behavior for something that is not running a GUI.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d64ec1d..7def82e 100644
--- a/Makefile
+++ b/Makefile
@@ -124,4 +124,4 @@ veryclean:
$(RM) qrouter.sh
.c.o:
- $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INC_SPECS) -c $< -o $@
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(SHLIB_CFLAGS) $(DEFS) $(INC_SPECS) -c $< -o $@