summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Edwards <tim@opencircuitdesign.com>2015-10-30 09:17:47 -0400
committerTim Edwards <tim@opencircuitdesign.com>2015-10-30 09:17:47 -0400
commit8257580ea0d644fabef5bfbca874b27ae47b220d (patch)
treeb7111491de6af1cd86fc97f3526de9a1077e92b7 /configure.in
parentf42d6286256d31a5f393e524a6b69d761fd213b7 (diff)
Corrected configuration to properly handle "prefix" in the
configure line.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e38ef80..88b8cba 100644
--- a/configure.in
+++ b/configure.in
@@ -162,12 +162,11 @@ fi
# Options
# =========================================
-QROUTER_LIB_DIR=${ac_default_prefix}/share/qrouter
+QROUTER_LIB_DIR="share/qrouter"
AC_ARG_WITH(libdir,
[ --with-libdir=DIR path to qrouter default config files], [
QROUTER_LIB_DIR=$withval
], [])
-AC_DEFINE_UNQUOTED(QROUTER_PATH, "$QROUTER_LIB_DIR")
# Interpreter Options
# =========================================
@@ -274,7 +273,7 @@ if test $usingTcl ; then
# 1. Search previously named locations.
for dir in \
- $prefix \
+ $ac_default_prefix \
$exec_prefix
do
if test -r "$dir/tclConfig.sh" ; then
@@ -361,7 +360,7 @@ if test $usingTcl ; then
# 1. Search previously named locations.
#
for dir in \
- $prefix \
+ $ac_default_prefix \
$exec_prefix
do
if test -r "$dir/tkConfig.sh" ; then