summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-02 15:14:54 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-02 15:14:54 +0200
commit5b8ff259e666a7ab38047153bc94dcc34ce3daf9 (patch)
tree6d55f858186b42f434329daca2ebb5436f521c13 /debian
parent511318b96bb666866dfb24babc8a28173cd2962d (diff)
Commit patch queue (exported by git-debrebase)
[git-debrebase: export and commit patches]
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/0003-FTCBFS-fails-to-propagate-the-cross-compiler-from-co.patch20
-rw-r--r--debian/patches/01_chmod_executable.patch25
-rw-r--r--debian/patches/02_use_tkcon_from_debian.patch37
-rw-r--r--debian/patches/series3
4 files changed, 85 insertions, 0 deletions
diff --git a/debian/patches/0003-FTCBFS-fails-to-propagate-the-cross-compiler-from-co.patch b/debian/patches/0003-FTCBFS-fails-to-propagate-the-cross-compiler-from-co.patch
new file mode 100644
index 0000000..9619d6c
--- /dev/null
+++ b/debian/patches/0003-FTCBFS-fails-to-propagate-the-cross-compiler-from-co.patch
@@ -0,0 +1,20 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Wed, 11 Jul 2018 13:01:29 +0200
+Subject: FTCBFS: fails to propagate the cross compiler from configure to make
+
+---
+ Makefile.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.in b/Makefile.in
+index a7b68ba..1329c06 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -3,6 +3,7 @@
+ #
+
+ # Main compiler arguments
++CC = @CC@
+ CFLAGS += @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
+ DEFS = @DEFS@
diff --git a/debian/patches/01_chmod_executable.patch b/debian/patches/01_chmod_executable.patch
new file mode 100644
index 0000000..c3aac6d
--- /dev/null
+++ b/debian/patches/01_chmod_executable.patch
@@ -0,0 +1,25 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Fri, 20 Feb 2015 00:00:00 +0100
+Subject: This sets the correct permission on console.tcl and qrouter.tcl
+
+===================================================================
+---
+ Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 95ed4d4..7586e15 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -110,9 +110,9 @@ install-tcl: qrouter.sh qrouter.tcl qrouter$(SHDLIB_EXT) \
+ $(INSTALL) qrouter$(SHDLIB_EXT) $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) qrouterexec$(EXEEXT) $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) qrouternullg$(EXEEXT) $(DESTDIR)${LIBINSTALL}
+- $(INSTALL) console.tcl $(DESTDIR)${LIBINSTALL}
++ $(INSTALL) -m 0644 console.tcl $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) tkcon.tcl $(DESTDIR)${LIBINSTALL}
+- $(INSTALL) qrouter.tcl $(DESTDIR)${LIBINSTALL}
++ $(INSTALL) -m 0644 qrouter.tcl $(DESTDIR)${LIBINSTALL}
+
+ uninstall:
+ $(RM) $(DESTDIR)${BININSTALL}/qrouter
diff --git a/debian/patches/02_use_tkcon_from_debian.patch b/debian/patches/02_use_tkcon_from_debian.patch
new file mode 100644
index 0000000..278a7de
--- /dev/null
+++ b/debian/patches/02_use_tkcon_from_debian.patch
@@ -0,0 +1,37 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Fri, 20 Feb 2015 00:00:00 +0100
+Subject: Use tkon from debian
+
+This patch makes sure that the tkcon version from debian is used instead of the version bundled with the source of qrouter.
+
+===================================================================
+---
+ Makefile.in | 1 -
+ qrouter.sh.in | 2 +-
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 7586e15..a7b68ba 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -111,7 +111,6 @@ install-tcl: qrouter.sh qrouter.tcl qrouter$(SHDLIB_EXT) \
+ $(INSTALL) qrouterexec$(EXEEXT) $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) qrouternullg$(EXEEXT) $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) -m 0644 console.tcl $(DESTDIR)${LIBINSTALL}
+- $(INSTALL) tkcon.tcl $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) -m 0644 qrouter.tcl $(DESTDIR)${LIBINSTALL}
+
+ uninstall:
+diff --git a/qrouter.sh.in b/qrouter.sh.in
+index 12bab42..8e7cbda 100755
+--- a/qrouter.sh.in
++++ b/qrouter.sh.in
+@@ -57,7 +57,7 @@ shift
+
+ if [ $TKCON ]; then
+
+- exec ${loclibdir}/tkcon.tcl \
++ exec /usr/bin/tkcon \
+ -eval "source ${loclibdir}/console.tcl" \
+ -slave "package require Tk; set argc $#; set argv [list $*]; \
+ source ${loclibdir}/qrouter.tcl"
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..1ecbe17
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+01_chmod_executable.patch
+02_use_tkcon_from_debian.patch
+0003-FTCBFS-fails-to-propagate-the-cross-compiler-from-co.patch