summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-13 15:47:35 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-13 15:47:35 +0200
commitc56d43735709cf7002e70d848e2abbec96a9fc18 (patch)
tree53bc63e2bc2c036e6facb23bacbeb7684ba0f724 /debian
parent578d73225f20affb1849f6d797ad475ac8391690 (diff)
Lintian
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
3 files changed, 8 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index b539845..350f2fc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,10 @@
qrouter (1.3.103-1) unstable; urgency=medium
* New upstream release
- * debian/compat: Set to 11
- * debian/control: debhelper >= 11
+ * debian/rules:
+ - Replace dpkg-parsechangelog with /usr/share/dpkg/pkg-info.mk
+ - Make the date formatting timezone independent using LC_ALL=C and
+ "date -u"
-- Ruben Undheim <ruben.undheim@gmail.com> Thu, 12 Jul 2018 23:23:40 +0200
diff --git a/debian/control b/debian/control
index 3592147..0e63bd1 100644
--- a/debian/control
+++ b/debian/control
@@ -31,4 +31,4 @@ Description: Multi-level, over-the-cell maze router
It takes the cell definitions from a LEF file, and analyzes the geometry for
each cell to determine contact points and route obstructions. It then reads
the cell placement, pin placement, and netlist from a DEF file, performs the
- detailed route, and writes an annotated DEF file as output.
+ detailed route, and writes an annotated DEF file as output.
diff --git a/debian/rules b/debian/rules
index 1955d22..0cc941d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,8 @@
#export DH_VERBOSE=1
+include /usr/share/dpkg/pkg-info.mk
+
# The build script crashes if "-pie" is given to the build command. Therefore
# enabling the missing hardening options with LDFLAGS_MAINT_APPEND (together
# with the --as-needed option) instead of with
@@ -9,7 +11,7 @@
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,now -Wl,--as-needed
-CHANGELOG_DATE ?= $(shell date -d "`dpkg-parsechangelog --show-field Date`" +"%d %B %Y")
+CHANGELOG_DATE ?= $(shell LC_ALL=C date -u -d @$(SOURCE_DATE_EPOCH) +"%d %B %Y")
%:
dh $@ --with autotools_dev,autoreconf