summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2015-10-18 20:29:55 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2015-10-18 20:31:55 +0200
commite65acd49db2a86da32917e3b3fc8e6f59573b607 (patch)
tree8431661fcc90fdf67cb68820d20aa63a402eebe3 /debian
parent9900979bbf6a65f4734f3f482e3908c9c1eb6b44 (diff)
Use txt2man to generate man page
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control3
-rwxr-xr-xdebian/man/genmanpages.sh4
-rw-r--r--debian/man/qrouter.txt44
-rw-r--r--debian/qrouter.158
-rw-r--r--debian/qrouter.manpages2
-rwxr-xr-xdebian/rules9
7 files changed, 63 insertions, 61 deletions
diff --git a/debian/changelog b/debian/changelog
index f8254fa..65d028c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,10 @@
qrouter (1.3.20-1) UNRELEASED; urgency=low
* New upstream release
+ * Use "txt2man" to generate man page from txt file
+ - Added d/man/genmanpages.sh, d/man/qrouter.txt and deleted
+ d/qrouter.1
+ - d/rules: Added rules to build man page during package build.
-- Ruben Undheim <ruben.undheim@gmail.com> Sun, 18 Oct 2015 10:57:42 +0200
diff --git a/debian/control b/debian/control
index dea03f6..c5207b2 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,8 @@ Build-Depends: debhelper (>= 9),
autotools-dev,
dh-autoreconf,
tcl-dev,
- tk-dev
+ tk-dev,
+ txt2man
Standards-Version: 3.9.6
Vcs-Browser: https://anonscm.debian.org/cgit/debian-science/packages/qrouter.git
Vcs-Git: git://anonscm.debian.org/debian-science/packages/qrouter.git
diff --git a/debian/man/genmanpages.sh b/debian/man/genmanpages.sh
new file mode 100755
index 0000000..dba27a5
--- /dev/null
+++ b/debian/man/genmanpages.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+
+txt2man -t QROUTER -s 1 qrouter.txt > qrouter.1
diff --git a/debian/man/qrouter.txt b/debian/man/qrouter.txt
new file mode 100644
index 0000000..e4151b2
--- /dev/null
+++ b/debian/man/qrouter.txt
@@ -0,0 +1,44 @@
+NAME
+ qrouter - Multi-level, over-the-cell maze router
+
+SYNOPSIS
+ qrouter [options] design_name
+
+DESCRIPTION
+ This manual page documents briefly the qrouter command.
+
+ Qrouter is a tool to generate metal layers and vias to physically connect together a netlist in a VLSI fabrication technology. It is a maze router, otherwise known as an "over-the-cell" router or "sea-of-gates" router. That is, unlike a channel router, it begins with a description of placed standard cells, usually packed together at minimum spacing, and places metal routes over the standard cells.
+
+ Qrouter uses the open standard LEF and DEF formats as file input and output. It takes the cell definitions from a LEF file, and analyzes the geometry for each cell to determine contact points and route obstructions. It then reads the cell placement, pin placement, and netlist from a DEF file, performs the detailed route, and writes an annotated DEF file as output.
+
+OPTIONS
+ -c <file> Configuration file name (if not route.cfg)
+
+ -v <level> Verbose output level
+
+ -i <name> Print route names and pitches and exit
+
+ -p <name> Specify global power bus name
+
+ -g <name> Specify global ground bus name
+
+
+INPUT
+ The input files for qrouter is an unrouted or partly routed .def file containing the
+ layout and a .cfg file containing the tcl script used to do the routing. The .cfg
+ file also needs to specify a .lef file describing the technology.
+
+
+OUTPUT
+ qrouter will output the fully routed .def file (if successful routing). This may
+ then later be converted to a GDSII file using tools such as magic.
+
+SEE ALSO
+ qflow(1)
+
+AUTHOR
+ qrouter was written by Tim Edwards <tim@opencircuitdesign.com>.
+
+ This manual page was written by Ruben Undheim <ruben.undheim@gmail.com>, for the
+ Debian project (and may be used by others).
+
diff --git a/debian/qrouter.1 b/debian/qrouter.1
deleted file mode 100644
index 1f9e52e..0000000
--- a/debian/qrouter.1
+++ /dev/null
@@ -1,58 +0,0 @@
-.\" Hey, EMACS: -*- nroff -*-
-.\" (C) Copyright 2014 Ruben Undheim <ruben.undheim@gmail.com>,
-.TH QROUTER 1 "September 30, 2015"
-.SH NAME
-qrouter \- Multi-level, over-the-cell maze router
-.SH SYNOPSIS
-.B qrouter
-.RI [ options ] " design_name"
-.br
-.SH DESCRIPTION
-This manual page documents briefly the
-.B qrouter
-command.
-.PP
-Qrouter is a tool to generate metal layers and vias to physically connect
-together a netlist in a VLSI fabrication technology. It is a maze router,
-otherwise known as an "over-the-cell" router or "sea-of-gates" router.
-That is, unlike a channel router, it begins with a description of placed
-standard cells, usually packed together at minimum spacing, and places
-metal routes over the standard cells.
-
-Qrouter uses the open standard LEF and DEF formats as file input and
-output. It takes the cell definitions from a LEF file, and analyzes the
-geometry for each cell to determine contact points and route
-obstructions. It then reads the cell placement, pin placement, and
-netlist from a DEF file, performs the detailed route, and writes an
-annotated DEF file as output.
-.\" TeX users may be more comfortable with the \fB<whatever>\fP and
-.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
-.\" respectively.
-.SH OPTIONS
-.TP
-.B \-c <file>
-Configuration file name (if not route.cfg)
-.TP
-.B \-v <level>
-Verbose output level
-.TP
-.B \-i <name>
-Print route names and pitches and exit
-.TP
-.B \-p <name>
-Specify global power bus name
-.TP
-.B \-g <name>
-Specify global ground bus name
-
-.SH INPUT
-The input files for qrouter is an unrouted or partly routed .def file containing the layout and a .cfg file containing the tcl script used to do the routing. The .cfg file also needs to specify a .lef file describing the technology.
-
-.SH OUTPUT
-qrouter will output the fully routed .def file (if successful routing). This may then later be converted to a GDSII file using tools such as magic.
-
-.SH AUTHOR
-qrouter was written by Tim Edwards <tim@opencircuitdesign.com>.
-.PP
-This manual page was written by Ruben Undheim <ruben.undheim@gmail.com>,
-for the Debian project (and may be used by others).
diff --git a/debian/qrouter.manpages b/debian/qrouter.manpages
index 64d2b50..13cdaf4 100644
--- a/debian/qrouter.manpages
+++ b/debian/qrouter.manpages
@@ -1 +1 @@
-debian/qrouter.1
+debian/man/*.1
diff --git a/debian/rules b/debian/rules
index fb8780c..9c09db7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,9 @@
# "DEB_BUILD_MAINT_OPTIONS = hardening=+all":
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,now -Wl,--as-needed
+
+CHANGELOG_DATE ?= $(shell date -d "`dpkg-parsechangelog --show-field Date`" +"%d %B %Y")
+
%:
dh $@ --with autotools_dev,autoreconf
@@ -16,9 +19,13 @@ override_dh_auto_configure:
dh_auto_configure -- --with-libdir=/usr/lib/qrouter
override_dh_auto_clean:
+ dh_auto_clean
$(RM) -f Makefile config.log config.status
$(RM) -f *.o
$(RM) -f *.so qrouterexec
$(RM) -f qrouter.sh qrouter.tcl
- dh_auto_clean
+ $(RM) debian/man/*.1
+override_dh_installman:
+ cd debian/man ; CHANGELOG_DATE="$(CHANGELOG_DATE)" ./genmanpages.sh
+ dh_installman