summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2022-08-30 22:10:09 -0700
committerDavid Bremner <bremner@debian.org>2022-08-30 22:10:09 -0700
commita396e1f3ad5b11dbc6c4a5d2e82506dfa953ef95 (patch)
tree434c2aeb0855f62e9335ab8ff5f971552e58d768
parent3ec949431811671795ec2c1069b263ab9c45dfe4 (diff)
Commit patch queue (exported by git-debrebase)debian/8.6+dfsg1-2archive/debian/8.6+dfsg1-2
[git-debrebase make-patches: export and commit patches]
-rw-r--r--debian/patches/0001-makefiles-restore-support-for-PLT_SETUP_OPTIONS-as-a.patch157
-rw-r--r--debian/patches/series1
2 files changed, 158 insertions, 0 deletions
diff --git a/debian/patches/0001-makefiles-restore-support-for-PLT_SETUP_OPTIONS-as-a.patch b/debian/patches/0001-makefiles-restore-support-for-PLT_SETUP_OPTIONS-as-a.patch
new file mode 100644
index 0000000000..a724bfc272
--- /dev/null
+++ b/debian/patches/0001-makefiles-restore-support-for-PLT_SETUP_OPTIONS-as-a.patch
@@ -0,0 +1,157 @@
+From: Matthew Flatt <mflatt@racket-lang.org>
+Date: Wed, 31 Aug 2022 10:53:48 +0800
+Subject: makefiles: restore support for `PLT_SETUP_OPTIONS` as an env var
+
+Treat `PLT_SETUP_OPTIONS` like `DESTDIR`, as something that can be set
+through an environment variable when using the "racket/src" makefile.
+
+(cherry picked from commit 261948f02a062728faa5b625e8d765b4fdaf7e16)
+---
+ src/Makefile.in | 25 +++++++++++++++----------
+ src/README.txt | 10 +++++++---
+ src/bc/Makefile.in | 1 +
+ src/cs/c/Makefile.in | 8 ++++++--
+ 4 files changed, 29 insertions(+), 15 deletions(-)
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 644d819..6a9172d 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -3,52 +3,57 @@
+
+ ZUO=bin/zuo
+
++# A few variables have traditionally been supported as environment
++# variables, so propagate uses (without definitions) here:
++INSTALL_VARS_FROM_ENV = DESTDIR="$(DESTDIR)" \
++ PLT_SETUP_OPTIONS="$(PLT_SETUP_OPTIONS)"
++
+ all: $(ZUO)
+ $(ZUO) . all
+
+ install: $(ZUO)
+- $(ZUO) . install DESTDIR="$(DESTDIR)"
++ $(ZUO) . install $(INSTALL_VARS_FROM_ENV)
+
+ plain-install: $(ZUO)
+- $(ZUO) . plain-install DESTDIR="$(DESTDIR)"
++ $(ZUO) . plain-install $(INSTALL_VARS_FROM_ENV)
+
+ .PHONY: cs
+ cs: $(ZUO)
+ $(ZUO) . cs
+
+ install-cs: $(ZUO)
+- $(ZUO) . install-cs DESTDIR="$(DESTDIR)"
++ $(ZUO) . install-cs $(INSTALL_VARS_FROM_ENV)
+
+ plain-install-cs: $(ZUO)
+- $(ZUO) . plain-install-cs DESTDIR="$(DESTDIR)"
++ $(ZUO) . plain-install-cs $(INSTALL_VARS_FROM_ENV)
+
+ .PHONY: bc
+ bc: $(ZUO)
+ $(ZUO) . bc
+
+ install-bc: $(ZUO)
+- $(ZUO) . install-bc DESTDIR="$(DESTDIR)"
++ $(ZUO) . install-bc $(INSTALL_VARS_FROM_ENV)
+
+ plain-install-bc: $(ZUO)
+- $(ZUO) . plain-install-bc DESTDIR="$(DESTDIR)"
++ $(ZUO) . plain-install-bc $(INSTALL_VARS_FROM_ENV)
+
+ 3m: $(ZUO)
+ $(ZUO) . 3m
+
+ install-3m: $(ZUO)
+- $(ZUO) . install-3m DESTDIR="$(DESTDIR)"
++ $(ZUO) . install-3m $(INSTALL_VARS_FROM_ENV)
+
+ plain-install-3m: $(ZUO)
+- $(ZUO) . plain-install-3m DESTDIR="$(DESTDIR)"
++ $(ZUO) . plain-install-3m $(INSTALL_VARS_FROM_ENV)
+
+ cgc: $(ZUO)
+ $(ZUO) . cgc
+
+ install-cgc: $(ZUO)
+- $(ZUO) . install-cgc DESTDIR="$(DESTDIR)"
++ $(ZUO) . install-cgc $(INSTALL_VARS_FROM_ENV)
+
+ plain-install-cgc: $(ZUO)
+- $(ZUO) . plain-install-cgc DESTDIR="$(DESTDIR)"
++ $(ZUO) . plain-install-cgc $(INSTALL_VARS_FROM_ENV)
+
+ $(ZUO):
+ mkdir -p bin
+diff --git a/src/README.txt b/src/README.txt
+index 1ddf12a..011d083 100644
+--- a/src/README.txt
++++ b/src/README.txt
+@@ -229,19 +229,23 @@ Detailed instructions:
+ libraries can find the installation directories. At this stage, in
+ case you are packaging an installation instead of installing
+ directly, you can redirect the installation by setting the
+- "DESTDIR" makefile variable to an absolute path for the
++ `DESTDIR` makefile variable to an absolute path for the
+ packaging area. For example, `make DESTDIR=/tmp/racket-build
+ install` places the installation into "/tmp/racket-build" instead
+ of the location originally specified with `--prefix`. The
+ resulting installation will not work, however, until it is moved
+- to the location originally specified with `--prefix`.
++ to the location originally specified with `--prefix`. When using
++ `make` instead of `zuo`, `DESTDIR` can be set as an environment
++ variable.
+
+ Finally, the `make install` step compiles ".zo" bytecode files for
+ installed Racket source, generates launcher programs like DrRacket
+ (if it's already installed as a package), and builds documentation
+ (again, if installed). Use `make plain-install` to install without
+ compiling ".zo" files, creating launchers, or building
+- documentation.
++ documentation. Supplying `PLT_SETUP_OPTIONS` (allowed as an
++ environment variable with `make`) sets flags that are passed on to
++ `raco setup` by `make install`.
+
+ For a `--prefix` build, unless `--enable-sharezo` is specified,
+ "compiled" directories containing ".zo" files are moved from
+diff --git a/src/bc/Makefile.in b/src/bc/Makefile.in
+index df3d35f..e91d901 100644
+--- a/src/bc/Makefile.in
++++ b/src/bc/Makefile.in
+@@ -84,6 +84,7 @@ CROSS_COMPILE_TARGET_KIND = @CROSS_COMPILE_TARGET_KIND@
+ SETUP_BOOT_MODE = @SETUP_BOOT_MODE@
+
+ INSTALL_SETUP_FLAGS = @INSTALL_SETUP_FLAGS@
++# PLT_SETUP_OPTIONS =
+ INSTALL_SETUP_RACKET_FLAGS = @INSTALL_SETUP_RACKET_FLAGS@
+ SETUP_MACHINE_FLAGS =
+
+diff --git a/src/cs/c/Makefile.in b/src/cs/c/Makefile.in
+index 96a4931..115cfc1 100644
+--- a/src/cs/c/Makefile.in
++++ b/src/cs/c/Makefile.in
+@@ -127,16 +127,20 @@ FRAMEWORK_INSTALL_DIR = @FRAMEWORK_INSTALL_DIR@
+ # installation "etc" directory
+ SELF_ROOT_CONFIG_DIR =
+
+-# Typically "--no-user":
++# Flags supplied to `raco` when installing, typically "--no-user";
++# values of two variable are appended for historical reasons
+ INSTALL_SETUP_FLAGS = @INSTALL_SETUP_FLAGS@
++PLT_SETUP_OPTIONS =
+
+ # Flags supplied to `racket` when running `raco` to set up
+ # packages and collections; the intent is to allow flags
+ # like `-MRC` to compile machine-independent bytecode
+ # while redirecting machine-specific bytecode to a separate
+ # filesystem tree, and/or `--cross-compiler` to support
+-# corss compilation
++# cross compilation; values of two variable are appended for
++# historical reasons
+ SETUP_MACHINE_FLAGS =
++INSTALL_SETUP_RACKET_FLAGS =
+
+ # Shell command to run after building an executable, where the
+ # just-built executable is added to the end of the command
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000000..0935f8fe94
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-makefiles-restore-support-for-PLT_SETUP_OPTIONS-as-a.patch