summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2024-03-08 12:45:34 -0400
committerDavid Bremner <david@tethera.net>2024-03-08 15:40:08 -0400
commitc2fec6e9e537815ed5cf805e1d5bffd9bc66daf7 (patch)
tree87a3663a68fb50b0f3233cee597c34e766ee6817 /debian
parent601f447e98cdcf3ed9586fe8833896d533b368db (diff)
debian: reboot packaging with minimal dh debian/rules
So far this is tested to build on amd64. Some of the install files needed to be adjusted because (I guess?) the previous complicated build strategy avoid some conflicts between arch:all packages.
Diffstat (limited to 'debian')
-rw-r--r--debian/clean3
-rw-r--r--debian/control3
-rwxr-xr-x[-rw-r--r--]debian/racket-common.install18
-rwxr-xr-xdebian/rules62
4 files changed, 15 insertions, 71 deletions
diff --git a/debian/clean b/debian/clean
index 91cd5f340a..567609b123 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1,2 +1 @@
-debian/racket-arch.mk
-debian/mzconfig.h
+build/
diff --git a/debian/control b/debian/control
index ea1ac6f338..bdd3cee422 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,7 @@ Section: lisp
Priority: optional
Maintainer: David Bremner <bremner@debian.org>
Standards-Version: 4.1.1
-Build-Depends: cdbs,
- debhelper (>= 10),
+Build-Depends: debhelper (>= 10),
libcairo2-dev,
libffi-dev,
libfreetype6-dev,
diff --git a/debian/racket-common.install b/debian/racket-common.install
index 2014974a2c..1b7e6fe862 100644..100755
--- a/debian/racket-common.install
+++ b/debian/racket-common.install
@@ -1,9 +1,9 @@
-usr/include
-usr/share/racket/collects
-usr/share/racket/pkgs
-usr/share/racket/links.rktd
-usr/share/racket/shares.rktd
-usr/share/racket/info-cache.rktd
-usr/share/man
-etc/racket
-usr/share/doc/racket/release
+#!/bin/sh
+echo "usr/include"
+find debian/tmp/usr/share/racket/collects -type f -not -name "*.zo" -not -name "*.dep"
+find debian/tmp/usr/share/racket/pkgs -type f -not -name "*.zo" -not -name "*.dep"
+echo "usr/share/racket/links.rktd"
+echo "usr/share/racket/shares.rktd"
+echo "usr/share/racket/info-cache.rktd"
+echo "usr/share/man"
+echo "etc/racket"
diff --git a/debian/rules b/debian/rules
index a39b041d40..fb0b5d4a60 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,61 +1,7 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/autotools.mk
+%:
+ dh $@ --builddir=build
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_CONFIGURE_SCRIPT := $(CURDIR)/src/configure
-DEB_CONFIGURE_EXTRA_FLAGS := --enable-libz --enable-liblz4
-MZDYN := mzdyn3m.o
-
-# most architectectures are supported only by the old pre-Chez backend
-ifeq (,$(filter $(DEB_HOST_ARCH),amd64 arm64 armhf i386))
- DEB_CONFIGURE_EXTRA_FLAGS += --enable-bcdefault
-endif
-
-# keep the collect build from using every available core, unless
-# explicitly enabled.
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_BITS),64)
- NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- else
- NUMJOBS = 1
- endif
-else
- NUMJOBS = 1
-endif
-
-ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- DEB_CONFIGURE_EXTRA_FLAGS += --enable-noopt
-endif
-
-DEB_CFLAGS_MAINT_APPEND := -O2
-export DEB_CFLAGS_MAINT_APPEND
-
-# Support for generating ".orig.tar.gz" from git
-
-SOURCEPKG=$(shell dpkg-parsechangelog | sed -n 's/^Source: \(.*\)/\1/p')
-UPSTREAM=$(shell dpkg-parsechangelog | sed -n 's/^Version: \(.*\)-[^-]*/\1/p')
-ORIG=${SOURCEPKG}_${UPSTREAM}.orig.tar.gz
-
-DEB_MAKE_ENVVARS += HOME=/nonexistant PLT_SETUP_OPTIONS="-j $(NUMJOBS) $(PLT_EXTRA)"
-
-DEB_BUILDDIR := $(DEB_SRCDIR)/build
-
-DEB_DH_INSTALL_ARGS_racket-common := -X.zo -X.dep -X$(MZDYN) -X/tests/
-DEB_DH_INSTALL_ARGS_racket-doc := -Xrelease
-DEB_DH_COMPRESS_ARGS := -X.sxref -X.sqlite
-
-# don't compress rkt source files since some are needed for
-# docs such as the quick.scrbl example and blueboxes.rktd files
-DEB_COMPRESS_EXCLUDE_ALL := .scrbl .rkt .rktd
-
-DEB_DH_BUILDDEB_ARGS := -- -Zxz
-
-# do not strip mzscheme, as this causes it to stop working
-# do not strip mred, as this fails on some arches
-DEB_DH_STRIP_ARGS_racket := -Xbin/mzscheme -Xbin/mred
-
-
-debian/racket-arch.mk: debian/racket-arch.c
- touch debian/mzconfig.h && cpp -Isrc -Idebian -o - $< | tail -1 > $@
+override_dh_auto_configure:
+ dh_auto_configure --sourcedir=src