summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2019-09-02 18:44:49 -0700
committerRuss Allbery <eagle@eyrie.org>2019-09-02 18:44:49 -0700
commit9dc108c48c719d27ff7538fbce2c3f072ec919f6 (patch)
treee05f73194997a62b585fedf35a1bffef36a7b8ac /.travis.yml
parenta74c724e0134176eae82de005da5cbf1a5b8f299 (diff)
Switch to setuptools and pytest for Python
Switch from distutils to setuptools so that proper dependencies can be specified in setup.py. Require pytest and pytest-runner and set up an alias so that test runs pytest. Move the test script into the tests subdirectory so that it will be found by pytest.
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml2
1 files changed, 1 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index ef630e1..b415d62 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -23,7 +23,7 @@ compiler:
before_install:
- sudo apt-get update -qq
- - sudo apt-get install -y cpanminus krb5-config libevent-dev libkrb5-dev libmodule-build-perl libpcre3-dev libtest-pod-perl libtest-pod-coverage-perl libtest-strict-perl libtest-synopsis-perl perl php-cli php-dev pkg-config python-all-dev ruby-all-dev
+ - sudo apt-get install -y cpanminus krb5-config libevent-dev libkrb5-dev libmodule-build-perl libpcre3-dev libtest-pod-perl libtest-pod-coverage-perl libtest-strict-perl libtest-synopsis-perl perl php-cli php-dev pkg-config python-all-dev python-pytest python-pytest-runner python-setuptools ruby-all-dev
- sudo cpanm Perl::Tidy
- sudo cpanm Perl::Critic || true
- sudo cpanm Test::MinimumVersion || true