summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2008-09-12 16:26:33 -0700
committerRuss Allbery <rra@stanford.edu>2008-09-12 16:26:33 -0700
commit1ac3a809fed572f7a20a530ec18e363e198322d3 (patch)
tree59cfe2777886590bb66b48b18b99c5f0c35bd072
parent700b74f08b0fb166eb2102a88a45e53f7c1f50d4 (diff)
Fix dependencies for builddir != srcdir
Several files for the language bindings are now generated by Autoconf. Fix the dependencies to expect those in the build directory rather than the source directory.
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ccd7ae3..07585b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -354,8 +354,7 @@ BINDINGS_INSTALL =
# which case we need to copy various files from the source directory and make
# sure they're up to date since Perl can't handle VPATH builds.
-perl/Remctl.o: $(srcdir)/perl/Remctl.pm $(srcdir)/perl/Remctl.xs \
- $(srcdir)/perl/typemap
+perl/Remctl.o: perl/Remctl.pm $(srcdir)/perl/Remctl.xs $(srcdir)/perl/typemap
set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
mkdir perl/t 2>/dev/null || true ; \
for f in $(PERL_FILES) ; do \
@@ -403,7 +402,7 @@ endif
# in which case we need to copy various files from the source directory and
# make sure they're up to date.
-build-local-python: $(srcdir)/python/_remctlmodule.c $(srcdir)/python/remctl.py
+build-local-python: $(srcdir)/python/_remctlmodule.c python/remctl.py
set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
for f in $(PYTHON_FILES) ; do \
cp "$(srcdir)/$$f" "$(builddir)/$$f" ; \