summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2009-05-13 01:23:28 -0700
committerRuss Allbery <rra@stanford.edu>2009-05-13 01:23:28 -0700
commitb37aae9fbc09680462a0fb44249ed5b98ca1f2a6 (patch)
tree11117b36cb085c216a20104b8add950c274cb0e5
parentf5fc6442c3e706e0be801cbd553bc9acedb5b620 (diff)
Add messages-die.obj where needed in Makefile.w32
-rw-r--r--Makefile.w324
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.w32 b/Makefile.w32
index 2c637d6..638ae36 100644
--- a/Makefile.w32
+++ b/Makefile.w32
@@ -4,12 +4,12 @@ cflags=$(cflags) /I $(KRB5SDK)\inc\krb5 /I $(KRB5SDK)\inc\krb5\gssapi /I . /D_CR
rcflags=$(rcflags) /I .
-remctl.exe: remctl.obj getopt.obj messages.obj asprintf.obj winsock.obj xmalloc.obj remctl.lib remctl.res
+remctl.exe: remctl.obj getopt.obj messages.obj messages-die.obj asprintf.obj winsock.obj xmalloc.obj remctl.lib remctl.res
link $(ldebug) $(lflags) /LIBPATH:$(KRB5SDK)\lib\$(CPU) /out:$@ $** ws2_32.lib advapi32.lib
remctl.lib: remctl.dll
-remctl.dll: api.obj client-v1.obj client-v2.obj error.obj open.obj network.obj asprintf.obj concat.obj gss-tokens.obj gss-errors.obj inet_aton.obj inet_ntop.obj strlcpy.obj strlcat.obj tokens.obj messages.obj winsock.obj xmalloc.obj libremctl.res
+remctl.dll: api.obj client-v1.obj client-v2.obj error.obj open.obj network.obj asprintf.obj concat.obj gss-tokens.obj gss-errors.obj inet_aton.obj inet_ntop.obj strlcpy.obj strlcat.obj tokens.obj messages.obj messages-die.obj winsock.obj xmalloc.obj libremctl.res
link $(ldebug) $(lflags) /LIBPATH:$(KRB5SDK)\lib\$(CPU) /dll /out:$@ /export:remctl /export:remctl_new /export:remctl_open /export:remctl_close /export:remctl_command /export:remctl_commandv /export:remctl_error /export:remctl_output $** gssapi32.lib ws2_32.lib advapi32.lib
{client\}.c{}.obj::