summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2014-04-08 19:11:29 -0700
committerRuss Allbery <eagle@eyrie.org>2014-04-08 19:20:47 -0700
commitea66056d29f42500af74f1dc1e52df2c930b77d5 (patch)
treecfa79ae1f0dd0e5e1e9a7d4297204eadec5fd5fa /debian/rules
parent684cd8ec01c8566236842c4a8bcf3ab6c9823775 (diff)
Fix new Ruby build method
dh_ruby --install has to be called explicitly. The debhelper add-on doesn't do that automatically since it assumes that Ruby will be detected as the top-level debhelper build system. Also add the Pre-Depends and XB-Ruby-Versions debian/control fields that use the dh_ruby substvars. Change-Id: I39185a8b6e548023b0a5ada91881d959681776e9
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 167e8b2..279cd02 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,10 +30,11 @@ override_dh_auto_configure:
--enable-python --enable-ruby
# Override install to check for missing installed files. Ignore the Ruby
-# module since dh_ruby takes care of installing the modules in the right
-# locations.
+# module installed by the upstream build system and run dh_ruby --install to
+# build and install the module for each supported Ruby version.
override_dh_install:
dh_install --fail-missing -Xlibremctl.la -Xsite_ruby/remctl.so
+ dh_ruby --install
override_dh_installchangelogs:
dh_installchangelogs NEWS