summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2016-05-07 14:56:38 -0700
committerRuss Allbery <eagle@eyrie.org>2016-05-07 14:56:38 -0700
commit49bb0c14235484df3c9d249d8f17afe099b80216 (patch)
treef13a9f13aeaa9e441ae3647d125eb885183781a1 /debian
parentf08b09e6a59f0cbc3beb33ff703da07960a8408c (diff)
Convert packaging to dh_php and PHP 7
* Convert packaging to use dh_php and build php-remctl instead of php5-remctl (and provide php7.0-remctl). There is no upgrade path defined from php5-remctl, since that seems to be the way other PHP packages are being handled during the upgrade.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control10
-rw-r--r--debian/php-remctl.docs (renamed from debian/php5-remctl.docs)0
-rw-r--r--debian/php-remctl.ini (renamed from debian/php5-remctl.ini)0
-rw-r--r--debian/php-remctl.install (renamed from debian/php5-remctl.install)0
-rw-r--r--debian/php-remctl.php1
-rwxr-xr-xdebian/rules5
7 files changed, 12 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index cdd1082..af322ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,10 @@ remctl (3.11-1) UNRELEASED; urgency=medium
* New upstream release.
- Port to PHP 7. (Closes: #821713)
+ * Convert packaging to use dh_php and build php-remctl instead of
+ php5-remctl (and provide php7.0-remctl). There is no upgrade path
+ defined from php5-remctl, since that seems to be the way other PHP
+ packages are being handled during the upgrade.
* Switch to the DEP-14 branch layout and update debian/gbp.conf and
Vcs-Git accordingly.
diff --git a/debian/control b/debian/control
index 3286bfe..d378280 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,7 @@ Priority: optional
Maintainer: Russ Allbery <rra@debian.org>
Build-Depends: debhelper (>= 9),
dh-autoreconf,
+ dh-php,
dpkg-dev (>= 1.14.9),
gem2deb (>= 0.4.1~),
krb5-config,
@@ -19,8 +20,8 @@ Build-Depends: debhelper (>= 9),
libtest-strict-perl,
libtest-synopsis-perl,
perl,
- php5-cli,
- php5-dev,
+ php-cli,
+ php-dev,
pkg-config,
python-all-dev
XS-Python-Version: >= 2.6
@@ -111,10 +112,11 @@ Description: Perl client for Kerberos-authenticated command execution
Net::Remctl::Backend module, which assists in writing remctl backends in
Perl.
-Package: php5-remctl
+Package: php-remctl
Section: php
Architecture: any
Depends: ${shlibs:Depends}, ${php:Depends}, ${misc:Depends}
+Provides: php7.0-remctl
Description: PECL module for Kerberos-authenticated command execution
remctl is a client/server protocol for executing specific commands on a
remote system with Kerberos authentication. The allowable commands must
@@ -123,7 +125,7 @@ Description: PECL module for Kerberos-authenticated command execution
associated with an ACL containing a list of Kerberos principals
authorized to run that command.
.
- This package contains the PECL remctl module for PHP 5, which provides
+ This package contains the PECL remctl module for PHP 7, which provides
native PHP bindings for the libremctl client library.
Package: python-remctl
diff --git a/debian/php5-remctl.docs b/debian/php-remctl.docs
index f1b25ab..f1b25ab 100644
--- a/debian/php5-remctl.docs
+++ b/debian/php-remctl.docs
diff --git a/debian/php5-remctl.ini b/debian/php-remctl.ini
index 1ad7f63..1ad7f63 100644
--- a/debian/php5-remctl.ini
+++ b/debian/php-remctl.ini
diff --git a/debian/php5-remctl.install b/debian/php-remctl.install
index 1ae6628..1ae6628 100644
--- a/debian/php5-remctl.install
+++ b/debian/php-remctl.install
diff --git a/debian/php-remctl.php b/debian/php-remctl.php
new file mode 100644
index 0000000..a283ffe
--- /dev/null
+++ b/debian/php-remctl.php
@@ -0,0 +1 @@
+mod debian/php-remctl.ini
diff --git a/debian/rules b/debian/rules
index b4074ea..fb0e13f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,7 @@ export REMCTL_PYTHON_INSTALL := --install-layout=deb
export REMCTL_PYTHON_VERSIONS := $(shell pyversions -s)
%:
- dh $@ --parallel --with python2,autoreconf,ruby
+ dh $@ --parallel --with python2,autoreconf,ruby,php
override_dh_autoreconf:
dh_autoreconf --as-needed
@@ -42,6 +42,3 @@ override_dh_installchangelogs:
override_dh_makeshlibs:
dh_makeshlibs -V 'libremctl1 (>= 3.1)'
-
-override_dh_gencontrol:
- dh_gencontrol -- -V"php:Depends=phpapi-`php-config5 --phpapi`"