summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2016-07-29 11:41:54 -0700
committerRuss Allbery <eagle@eyrie.org>2016-07-29 11:41:54 -0700
commitea6572b668c5e822c0d4decc55284f489a481f28 (patch)
tree11546b01a756736a7151a9b2e64c6d5af642a501 /debian
parent93d96fd49ecfc9d8a00e39e9827cd32a90f4b925 (diff)
Hardcode the sudo path in the build
* Hard-code the path to sudo in the build so that the sudo package doesn't have to be installed when building the package.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules5
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index fd5fec9..d9248ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ remctl (3.12-1) UNRELEASED; urgency=medium
would like to see that, file a bug.)
- New server configuration option, sudo, which says to change users
with sudo when running the command.
+ * Hard-code the path to sudo in the build so that the sudo package
+ doesn't have to be installed when building the package.
-- Russ Allbery <rra@debian.org> Fri, 29 Jul 2016 11:39:59 -0700
diff --git a/debian/rules b/debian/rules
index 642df0d..2a4c016 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,10 +24,11 @@ override_dh_autoreconf:
dh_autoreconf --as-needed
override_dh_auto_configure:
- dh_auto_configure --parallel -- --sysconfdir=/etc/remctl \
+ dh_auto_configure --parallel -- PATH_SUDO=/usr/bin/sudo \
+ --sysconfdir=/etc/remctl \
--with-systemdsystemunitdir=/lib/systemd/system \
--enable-reduced-depends --enable-perl --enable-php \
- --enable-python --enable-ruby
+ --enable-python x--enable-ruby
# Override install to check for missing installed files. Ignore the Ruby
# module installed in usr/local/lib by the upstream build system. Run