summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRazrFalcon <razrfalcon@gmail.com>2018-12-13 14:34:12 +0200
committerRazrFalcon <razrfalcon@gmail.com>2018-12-13 14:34:12 +0200
commit9b2becfacc3dae353b0df2df0a2eb5f0b01ad622 (patch)
treec5263153d512f983a7636ff201a260a466602012
parent60cb050701e8f5af8fc9f7e7bda39c4a4515d4a0 (diff)
Version bump.
-rw-r--r--.github/chart.svg8
-rw-r--r--CHANGELOG.md5
-rw-r--r--Cargo.lock28
-rw-r--r--Cargo.toml10
-rw-r--r--capi/Cargo.toml2
-rw-r--r--src/lib.rs2
-rw-r--r--testing_tools/regression/allow-cairo.txt2
-rw-r--r--testing_tools/regression/allow-qt.txt2
-rw-r--r--tools/rendersvg/Cargo.toml2
9 files changed, 28 insertions, 33 deletions
diff --git a/.github/chart.svg b/.github/chart.svg
index 9cd2cdb..f4bd069 100644
--- a/.github/chart.svg
+++ b/.github/chart.svg
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Generated by https://github.com/RazrFalcon/barh -->
<svg height="293" shape-rendering="crispEdges" width="841" xmlns="http://www.w3.org/2000/svg">
- <text font-family="Arial" font-size="16" x="61" y="38">resvg 0.4.0</text>
+ <text font-family="Arial" font-size="16" x="61" y="36">resvg 0.4.0</text>
<text font-family="Arial" font-size="16" x="56" y="71">Firefox 64.0</text>
<text font-family="Arial" font-size="16" x="4" y="104">Chromium r609904</text>
<text font-family="Arial" font-size="16" x="27" y="137">Inkscape 0.92.2</text>
@@ -19,9 +19,9 @@
<rect fill="#ccc" height="242" width="1" x="827" y="10"/>
<text fill="#000" font-family="Arial" font-size="16" x="814" y="266">815</text>
<rect fill="#3260cd" height="22" width="651" x="144" y="21"/>
- <text fill="#fff" font-family="Arial" font-size="16" x="765" y="38">778</text>
- <rect fill="#3260cd" height="22" width="633" x="144" y="54"/>
- <text fill="#fff" font-family="Arial" font-size="16" x="747" y="71">756</text>
+ <text fill="#fff" font-family="Arial" font-size="16" x="765" y="36">777</text>
+ <rect fill="#3260cd" height="22" width="634" x="144" y="54"/>
+ <text fill="#fff" font-family="Arial" font-size="16" x="748" y="71">757</text>
<rect fill="#3260cd" height="22" width="622" x="144" y="87"/>
<text fill="#fff" font-family="Arial" font-size="16" x="736" y="104">743</text>
<rect fill="#3260cd" height="22" width="542" x="144" y="120"/>
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 1f1b10b..7e65d4b 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -7,7 +7,10 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
This changelog also contains important changes in dependencies.
## [Unreleased]
+
+## [0.4.0] - 2018-12-13
### Added
+- (resvg) Initial filters support.
- (resvg) Nested `clipPath` and `mask` support.
- (resvg) MSVC support.
- (rendersvg) `font-family`, `font-size` and `languages` to args.
@@ -32,7 +35,7 @@ This changelog also contains important changes in dependencies.
- (usvg) `display` attribute processing.
- (usvg) Recursive `mask` resolving.
- (usvg) `inherit` attribute value resolving.
-- (svgdom) Namespaces resolving.
+- (svgdom) XML namespaces resolving.
### Removed
- (rendersvg) `failure` dependency.
diff --git a/Cargo.lock b/Cargo.lock
index 81e5980..1bb0e7c 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -49,7 +49,7 @@ dependencies = [
"gio 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
"gtk 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "resvg 0.3.0",
+ "resvg 0.4.0",
]
[[package]]
@@ -451,45 +451,45 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "rendersvg"
-version = "0.3.0"
+version = "0.4.0"
dependencies = [
"fern 0.5.7 (registry+https://github.com/rust-lang/crates.io-index)",
"gumdrop 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "resvg 0.3.0",
+ "resvg 0.4.0",
"time 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "resvg"
-version = "0.3.0"
+version = "0.4.0"
dependencies = [
"cairo-rs 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"gdk-pixbuf 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
"pango 0.5.0 (registry+https://github.com/rust-lang/crates.io-index)",
"pangocairo 0.6.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "resvg-qt 0.3.0 (git+https://github.com/RazrFalcon/resvg-qt?rev=0fde4c9)",
+ "resvg-qt 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
"rgb 0.8.11 (registry+https://github.com/rust-lang/crates.io-index)",
"unicode-segmentation 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
- "usvg 0.3.0 (git+https://github.com/RazrFalcon/usvg?rev=1f298f6)",
+ "usvg 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "resvg-capi"
-version = "0.3.0"
+version = "0.4.0"
dependencies = [
"cairo-sys-rs 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
"fern 0.5.7 (registry+https://github.com/rust-lang/crates.io-index)",
"glib 0.6.0 (registry+https://github.com/rust-lang/crates.io-index)",
"log 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "resvg 0.3.0",
+ "resvg 0.4.0",
]
[[package]]
name = "resvg-qt"
-version = "0.3.0"
-source = "git+https://github.com/RazrFalcon/resvg-qt?rev=0fde4c9#0fde4c965770f913467b79b97b7acf92bbabaf7b"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
dependencies = [
"cc 1.0.26 (registry+https://github.com/rust-lang/crates.io-index)",
"pkg-config 0.3.14 (registry+https://github.com/rust-lang/crates.io-index)",
@@ -581,8 +581,8 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "usvg"
-version = "0.3.0"
-source = "git+https://github.com/RazrFalcon/usvg?rev=1f298f6#1f298f6b87583fd3f28dd89e5c9fcd32930b3cad"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
dependencies = [
"base64 0.9.3 (registry+https://github.com/rust-lang/crates.io-index)",
"libflate 0.1.19 (registry+https://github.com/rust-lang/crates.io-index)",
@@ -664,7 +664,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
"checksum quote 0.6.10 (registry+https://github.com/rust-lang/crates.io-index)" = "53fa22a1994bd0f9372d7a816207d8a2677ad0325b073f5c5332760f0fb62b5c"
"checksum rctree 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "1817e0f0056f95bce0d6ab1a5be62ca24bd756b5547c20637ef47cc9a2065f4b"
"checksum redox_syscall 0.1.44 (registry+https://github.com/rust-lang/crates.io-index)" = "a84bcd297b87a545980a2d25a0beb72a1f490c31f0a9fde52fca35bfbb1ceb70"
-"checksum resvg-qt 0.3.0 (git+https://github.com/RazrFalcon/resvg-qt?rev=0fde4c9)" = "<none>"
+"checksum resvg-qt 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "0c2efacc41fc639ff3bf9c02c923a69a1cff354ef4fffbb772be45fbfdeb7f30"
"checksum rgb 0.8.11 (registry+https://github.com/rust-lang/crates.io-index)" = "002bebda58b24482d6911a59512e8a17fa1defecf5a2162521113b7cc5422dd1"
"checksum roxmltree 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "869a77456372218c6cd28ae457bedbc338af19866290e71d71965cc992e2654b"
"checksum safemem 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)" = "8dca453248a96cb0749e36ccdfe2b0b4e54a61bfef89fb97ec621eb8e0a93dd9"
@@ -677,7 +677,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
"checksum time 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)" = "d825be0eb33fda1a7e68012d51e9c7f451dc1a69391e7fdc197060bb8c56667b"
"checksum unicode-segmentation 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "aa6024fc12ddfd1c6dbc14a80fa2324d4568849869b779f6bd37e5e4c03344d1"
"checksum unicode-xid 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "fc72304796d0818e357ead4e000d19c9c174ab23dc11093ac919054d20a6a7fc"
-"checksum usvg 0.3.0 (git+https://github.com/RazrFalcon/usvg?rev=1f298f6)" = "<none>"
+"checksum usvg 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "f9ebf4d5244ba2e8305caf9de7949377794ecdea5a9e3c84fc5610d78d21f5ee"
"checksum winapi 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)" = "92c1eb33641e276cfa214a0522acad57be5c56b10cb348b3c5117db75f3ac4b0"
"checksum winapi-i686-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
"checksum winapi-x86_64-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
diff --git a/Cargo.toml b/Cargo.toml
index 3385475..cca1f34 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "resvg"
# When updating version, also modify html_root_url in the lib.rs, in the README and in the rendersvg
-version = "0.3.0"
+version = "0.4.0"
authors = ["Evgeniy Reizner <razrfalcon@gmail.com>"]
keywords = ["svg", "render", "raster"]
license = "MPL-2.0"
@@ -30,9 +30,7 @@ travis-ci = { repository = "RazrFalcon/resvg" }
[dependencies]
log = "0.4.5"
rgb = "0.8.9"
-#usvg = "0.2"
-usvg = { git = "https://github.com/RazrFalcon/usvg", rev = "1f298f6" }
-#usvg = { path = "../usvg" }
+usvg = "0.4"
unicode-segmentation = "1.2.1"
# cairo backend
@@ -42,9 +40,7 @@ pango = { version = "0.5", optional = true }
pangocairo = { version = "0.6", optional = true }
# qt backend
-#resvg-qt = { version = "0.3", optional = true }
-resvg-qt = { git = "https://github.com/RazrFalcon/resvg-qt", rev = "0fde4c9", optional = true }
-#resvg-qt = { path = "../resvg-qt", optional = true }
+resvg-qt = { version = "0.4", optional = true }
[features]
cairo-backend = ["cairo-rs", "pango", "pangocairo", "gdk-pixbuf"]
diff --git a/capi/Cargo.toml b/capi/Cargo.toml
index 3924a52..20d92cf 100644
--- a/capi/Cargo.toml
+++ b/capi/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "resvg-capi"
-version = "0.3.0"
+version = "0.4.0"
authors = ["Evgeniy Reizner <razrfalcon@gmail.com>"]
keywords = ["svg", "render", "raster", "capi"]
license = "MPL-2.0"
diff --git a/src/lib.rs b/src/lib.rs
index 506d7fc..039e2ed 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -14,7 +14,7 @@ It can be used as a simple SVG to PNG converted.
And as an embeddable library to paint SVG on an application native canvas.
*/
-#![doc(html_root_url = "https://docs.rs/resvg/0.3.0")]
+#![doc(html_root_url = "https://docs.rs/resvg/0.4.0")]
//#![forbid(unsafe_code)]
#![warn(missing_docs)]
diff --git a/testing_tools/regression/allow-cairo.txt b/testing_tools/regression/allow-cairo.txt
index 1de25af..e69de29 100644
--- a/testing_tools/regression/allow-cairo.txt
+++ b/testing_tools/regression/allow-cairo.txt
@@ -1,2 +0,0 @@
-e-feFlood-006.svg
-e-filter-041.svg
diff --git a/testing_tools/regression/allow-qt.txt b/testing_tools/regression/allow-qt.txt
index 1de25af..e69de29 100644
--- a/testing_tools/regression/allow-qt.txt
+++ b/testing_tools/regression/allow-qt.txt
@@ -1,2 +0,0 @@
-e-feFlood-006.svg
-e-filter-041.svg
diff --git a/tools/rendersvg/Cargo.toml b/tools/rendersvg/Cargo.toml
index bc3b4b5..8bd0514 100644
--- a/tools/rendersvg/Cargo.toml
+++ b/tools/rendersvg/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "rendersvg"
-version = "0.3.0"
+version = "0.4.0"
authors = ["Evgeniy Reizner <razrfalcon@gmail.com>"]
keywords = ["svg", "render", "raster"]
license = "MPL-2.0"