summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRazrFalcon <razrfalcon@gmail.com>2018-12-16 17:18:20 +0200
committerRazrFalcon <razrfalcon@gmail.com>2018-12-16 17:18:20 +0200
commit3b596797c5515e192b4a11912c8e3b26902228f9 (patch)
tree1d458478fe0f92477512ecf0ba232b3a0f353370 /Cargo.toml
parent0b2514e2aad8c0740c83f41645ac1f507db96bd1 (diff)
The usvg repo is a subproject now.
usvg is the core part of the resvg and it was troublesome to develop it in a separate repo.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 40baddf..d696a9e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,13 +15,13 @@ categories = ["multimedia::images"]
members = [
"capi",
"tools/rendersvg",
+ "tools/usvg",
"examples/cairo-rs",
+ "usvg",
]
exclude = [
"examples/cairo-rs",
"testing_tools",
- "workdir-qt", # for CI tests
- "workdir-cairo", # for CI tests
]
[badges]
@@ -30,8 +30,8 @@ travis-ci = { repository = "RazrFalcon/resvg" }
[dependencies]
log = "0.4.5"
rgb = "0.8.9"
-usvg = { git = "https://github.com/RazrFalcon/usvg", rev = "5346684" }
-#usvg = { path = "../usvg" }
+#usvg = { git = "https://github.com/RazrFalcon/usvg", rev = "5346684" }
+usvg = { path = "./usvg" }
unicode-segmentation = "1.2.1"
# cairo backend
@@ -44,7 +44,7 @@ pangocairo = { version = "0.6", optional = true }
resvg-qt = { version = "0.4", optional = true }
[features]
-cairo-backend = ["cairo-rs", "pango", "pangocairo", "gdk-pixbuf"]
+cairo-backend = ["cairo-rs", "gdk-pixbuf", "pango", "pangocairo"]
qt-backend = ["resvg-qt"]
[lib]