summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorReizner Evgeniy <razrfalcon@gmail.com>2018-04-21 18:37:25 +0300
committerReizner Evgeniy <razrfalcon@gmail.com>2018-04-21 18:37:25 +0300
commit5741de862256742ec99c9c0888cb02ff9f5a1e2e (patch)
tree89e69259068240b6091970f8dcd6859abdc610e7 /Cargo.toml
parentb5e74035cc7be5eca06b82972cdcfd626097481e (diff)
Cargo.toml refactoring.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml37
1 files changed, 6 insertions, 31 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2175d1f..2688ebb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -30,37 +30,12 @@ euclid = "0.17"
failure = "0.1.1"
log = "0.4"
lyon_geom = "0.10"
-
-[dependencies.pango]
-version = "0.4"
-optional = true
-
-[dependencies.pangocairo]
-version = "0.5.0"
-optional = true
-
-[dependencies.cairo-rs]
-version = "0.4.1"
-features = ["png"]
-optional = true
-
-[dependencies.resvg-qt]
-git = "https://github.com/RazrFalcon/resvg-qt"
-# path = "../resvg-qt"
-# version = "0.1.0"
-rev = "9a5b017"
-optional = true
-
-[dependencies.usvg]
-git = "https://github.com/RazrFalcon/usvg"
-rev = "3eef07c"
-#path = "../usvg"
-
-[dependencies.image]
-version = "0.18"
-default-features = false
-features = ["jpeg", "png_codec"]
-optional = true
+pango = { version = "0.4", optional = true }
+pangocairo = { version = "0.5", optional = true }
+cairo-rs = { version = "0.4.1", features = ["png"], optional = true }
+resvg-qt = { git = "https://github.com/RazrFalcon/resvg-qt", rev = "9a5b017", optional = true }
+usvg = { git = "https://github.com/RazrFalcon/usvg", rev = "3eef07c" }
+image = { version = "0.18", default-features = false, features = ["jpeg", "png_codec"], optional = true }
[features]
cairo-backend = ["cairo-rs", "pango", "pangocairo", "image"]