summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRazrFalcon <razrfalcon@gmail.com>2018-12-27 16:30:07 +0200
committerRazrFalcon <razrfalcon@gmail.com>2018-12-27 16:50:06 +0200
commitf5a08a2faccd23111dcfa89eed4c3bd56400f72e (patch)
treefe68a2ec2512fa68a7eab73af078b8fa57381301 /Cargo.toml
parent1a55fa11d2bc63d609b0e265aa94cd7747337dd7 (diff)
Move Qt bindings to this repo.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 3 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cd73d44..4b4d50b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,10 +18,7 @@ members = [
"tools/usvg",
"examples/cairo-rs",
"usvg",
-]
-exclude = [
- "examples/cairo-rs",
- "testing_tools",
+ "resvg-qt",
]
[badges]
@@ -30,7 +27,7 @@ travis-ci = { repository = "RazrFalcon/resvg" }
[dependencies]
log = "0.4.5"
rgb = "0.8.9"
-usvg = { path = "usvg" }
+usvg = { path = "usvg", version = "0.4.0" }
unicode-segmentation = "1.2.1" # TODO: reexport?
# cairo backend
@@ -40,8 +37,7 @@ pango = { version = "0.5", optional = true }
pangocairo = { version = "0.6", optional = true }
# qt backend
-#resvg-qt = { version = "0.4", optional = true }
-resvg-qt = { git = "https://github.com/RazrFalcon/libresvg-qt", rev = "4dd0b40", optional = true }
+resvg-qt = { path = "resvg-qt", version = "0.4.0", optional = true }
[features]
cairo-backend = ["cairo-rs", "gdk-pixbuf", "pango", "pangocairo"]