summaryrefslogtreecommitdiff
path: root/capi
diff options
context:
space:
mode:
authorRazrFalcon <razrfalcon@gmail.com>2019-01-04 00:17:22 +0200
committerRazrFalcon <razrfalcon@gmail.com>2019-01-04 00:17:22 +0200
commit5e7d864acd1f089caf300c0b44bfeccb220eb8ea (patch)
tree857200f4842f123fd41b891025be7cd698e25d49 /capi
parentbd81f7aee6cb71b4989dd7b98fb7c2c0fa77cc3f (diff)
Build static library for C-API too.
Diffstat (limited to 'capi')
-rw-r--r--capi/Cargo.toml2
-rw-r--r--capi/README.md3
2 files changed, 1 insertions, 4 deletions
diff --git a/capi/Cargo.toml b/capi/Cargo.toml
index 20d92cf..6084900 100644
--- a/capi/Cargo.toml
+++ b/capi/Cargo.toml
@@ -8,7 +8,7 @@ workspace = ".."
[lib]
name = "resvg"
-crate-type = ["cdylib"]
+crate-type = ["cdylib", "staticlib"]
[dependencies]
fern = "0.5"
diff --git a/capi/README.md b/capi/README.md
index 51d8e5c..a361e3a 100644
--- a/capi/README.md
+++ b/capi/README.md
@@ -13,9 +13,6 @@ cargo build --release --features="qt-backend cairo-backend"
See [BUILD.adoc](../BUILD.adoc) for details.
-This will build a dynamic library. There is no point in building the static
-library since it will depend on Qt/cairo anyway.
-
## Examples
A usage example with a *cairo* backend can be found at [examples/cairo-capi](../examples/cairo-capi).