summaryrefslogtreecommitdiff
path: root/tools/kde-dolphin-thumbnailer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/kde-dolphin-thumbnailer/CMakeLists.txt')
-rw-r--r--tools/kde-dolphin-thumbnailer/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/tools/kde-dolphin-thumbnailer/CMakeLists.txt b/tools/kde-dolphin-thumbnailer/CMakeLists.txt
new file mode 100644
index 0000000..822c73c
--- /dev/null
+++ b/tools/kde-dolphin-thumbnailer/CMakeLists.txt
@@ -0,0 +1,35 @@
+project(resvgthumbnailer)
+
+cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
+set(QT_MIN_VERSION "5.6.0")
+
+find_package(ECM 1.0.0 REQUIRED NO_MODULE)
+set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
+
+include(FeatureSummary)
+include(WriteBasicConfigVersionFile)
+include(KDEInstallDirs)
+include(KDECMakeSettings)
+include(KDECompilerSettings NO_POLICY_SCOPE)
+
+find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS Core Gui)
+find_package(KF5 REQUIRED COMPONENTS KIO I18n Config)
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../capi/include
+)
+
+set(resvgthumbnailer_PART_SRCS
+ resvgthumbnailer.cpp
+)
+
+add_library(resvgthumbnailer MODULE ${resvgthumbnailer_PART_SRCS})
+
+target_link_libraries(resvgthumbnailer Qt5::Core Qt5::Gui KF5::KIOWidgets KF5::KIOCore KF5::I18n KF5::ConfigCore KF5::ConfigGui resvg)
+
+install(TARGETS resvgthumbnailer DESTINATION ${PLUGIN_INSTALL_DIR})
+
+########### install files ###############
+
+install(FILES resvgthumbnailer.desktop DESTINATION ${SERVICES_INSTALL_DIR})