summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Kettlewell <rjk@terraraq.org.uk>2019-03-03 11:05:04 +0000
committerRichard Kettlewell <rjk@terraraq.org.uk>2019-03-03 11:05:04 +0000
commita63505d4d87ea110b3a4fe65bd863c120b1b276e (patch)
tree7402bc9630908dc7d75434794ee73f62f0a31186
parent5cca82b5a0e6fcf1b4a39f63d52f4d4d00fa85f3 (diff)
debian: update standards version a little
...& add a checklist for all things not investigated.
-rw-r--r--Makefile.am1
-rw-r--r--debian/CHECKLIST.md61
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules8
4 files changed, 68 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d4162ad..f1a6553 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,7 @@ EXTRA_DIST=scripts/fakeshell.sh \
debian/doc.rsbackup \
debian/rsbackup.conffiles debian/rsbackup.postinst debian/rules \
debian/rsbackup.postrm \
+ debian/CHECKLIST.md \
README.md
dist_noinst_SCRIPTS=scripts/txt2src scripts/htmlman scripts/dist \
scripts/travis/linux/clang/configure \
diff --git a/debian/CHECKLIST.md b/debian/CHECKLIST.md
new file mode 100644
index 0000000..2b037a7
--- /dev/null
+++ b/debian/CHECKLIST.md
@@ -0,0 +1,61 @@
+# Debian standards checklist
+
+Things that need attention are listed below.
+Their presence here doesn't mean a change is definitely required, but it should be looked into.
+
+## 3.9.7
+
+* 12.3 recommend to ship additional documentation for package "pkg" in a separate package "pkg-doc" and install it into "/usr/share/doc/pkg".
+ * See also 4.0.0.0 12.3 (*-doc deps should be at most Recommends)
+
+## 3.9.8
+
+Nothing relevant.
+
+## 4.0.0
+
+* 4.3 "config.sub" and "config.guess" should be updated at build time or replaced with the versions from autotools-dev.
+* 4.9.1 New "DEB\_BUILD\_OPTIONS" tag, "nodoc", which says to suppress documentation generation (but continue to build all binary packages, even documentation packages, just let them be mostly empty).
+
+## 4.0.1
+
+Nothing relevant.
+
+## 4.1.0
+
+* 4.11 If upstream provides OpenPGP signatures, including the upstream signing key as "debian/upstream/signing-key.asc" in the source package and using the "pgpsigurlmangle" option in "debian/watch" configuration to indicate how to find the upstream signature for new releases is recommended.
+* 4.15 Packages should build reproducibly when certain factors are held constant; see 4.15 for the list.
+
+## 4.1.1
+
+Nothing relevant.
+
+## 4.1.2
+
+Nothing relevant.
+
+## 4.1.3
+
+* 5.6.26 URLs given in "VCS-*" headers should use a scheme that provides confidentiality ("https", for example) if the VCS repository supports it. "[vcs-field-uses-insecure-uri]" _should add VCS headers_
+
+## 4.1.4
+
+Nothing relevant.
+
+## 4.1.5
+
+Nothing relevant.
+
+## 4.2.0
+
+* ~~4.9 The package build should be as verbose as reasonably possible. This means that "debian/rules" should pass to the commands it invokes options that cause them to produce verbose output.~~
+* 12.7 Upstream release notes, when available, should be installed as "/usr/share/doc/package/NEWS.gz". Upstream changelogs may be made available as "/usr/share/doc/package/changelog.gz".
+
+## 4.2.1
+
+Nothing relevant.
+
+## 4.3.0
+
+* ~~10.1 Binaries should be stripped using "strip --strip-unneeded --remove- section=.comment --remove-section=.note" (as dh\_strip already does).~~
+
diff --git a/debian/control b/debian/control
index 56a4783..0ea72a1 100644
--- a/debian/control
+++ b/debian/control
@@ -2,9 +2,9 @@ Source: rsbackup
Maintainer: Debian rsbackup maintainers <rsbackup-maint@lists.alioth.debian.org>
Uploaders: Matthew Vernon <matthew@debian.org>
Priority: optional
-Standards-Version: 3.9.5.0
+Standards-Version: 3.9.6.0
Section: admin
-Homepage: http://www.greenend.org.uk/rjk/rsbackup/
+Homepage: https://www.greenend.org.uk/rjk/rsbackup/
Build-Depends: lynx|lynx-cur,devscripts,sqlite3,libsqlite3-dev,libboost-system-dev,libboost-filesystem-dev,libboost-dev,pkg-config,libpangomm-1.4-dev,libcairomm-1.0-dev,xattr,acl
Package: rsbackup
diff --git a/debian/rules b/debian/rules
index ed79692..47b1bd0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,7 @@
INSTALL=install
VERSION=5.0
+STRIPARGS=--strip-unneeded --remove-section=.comment --remove-section=.note
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
@@ -32,7 +33,7 @@ build-arch: build
build-indep: build
build:
[ -e configure ] || autoreconf -si
- ./configure --prefix=/usr --mandir=/usr/share/man ${CONFIGURE_EXTRA}
+ ./configure --prefix=/usr --mandir=/usr/share/man --disable-silent-rules ${CONFIGURE_EXTRA}
$(MAKE)
clean-rsbackup:
@@ -77,7 +78,7 @@ binary-rsbackup: build
doc/rsbackup-snapshot-hook.1 \
debian/rsbackup/usr/share/man/man1/
$(INSTALL) -m 644 doc/rsbackup.5 debian/rsbackup/usr/share/man/man5/
- strip --remove-section=.comment debian/rsbackup/usr/bin/rsbackup
+ strip $(STRIPARGS) debian/rsbackup/usr/bin/rsbackup
gzip -9nv debian/rsbackup/usr/share/man/man*/*
dpkg-shlibdeps -Tdebian/substvars.rsbackup \
debian/rsbackup/usr/bin/*
@@ -108,8 +109,7 @@ binary-rsbackup-graph: build
debian/rsbackup-graph/usr/bin/rsbackup-graph
$(INSTALL) -m 644 doc/rsbackup-graph.1 \
debian/rsbackup-graph/usr/share/man/man1/
- strip --remove-section=.comment \
- debian/rsbackup-graph/usr/bin/rsbackup-graph
+ strip $(STRIPARGS) debian/rsbackup-graph/usr/bin/rsbackup-graph
gzip -9nv debian/rsbackup-graph/usr/share/man/man*/*
dpkg-shlibdeps -Tdebian/substvars.rsbackup-graph \
debian/rsbackup-graph/usr/bin/*