summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2019-09-24 23:20:11 +0200
committerJohannes 'josch' Schauer <josch@debian.org>2019-09-25 00:04:32 +0200
commit98c2bee51824568b0ba827d4e32f2f1ef9c4e4ea (patch)
treef09d89581aaaa8e84e9f3276297142a2efcd7786 /debian
parent8e4208e29e4a8a33a57cc95af6a492d69c68b899 (diff)
use phpcomposer from pkg-php-tools
Diffstat (limited to 'debian')
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules2
2 files changed, 5 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 41d8e74..af5acfa 100644
--- a/debian/control
+++ b/debian/control
@@ -6,13 +6,14 @@ Homepage: https://github.com/RSS-Bridge/rss-bridge
Vcs-Browser: https://browse.dgit.debian.org/rss-bridge.git/
Vcs-Git: https://git.dgit.debian.org/rss-bridge
Standards-Version: 4.1.3
-Build-Depends: debhelper (>= 11), php-cli
+Build-Depends: debhelper (>= 11), pkg-php-tools (>= 1.7~)
Rules-Requires-Root: binary-targets
Package: rss-bridge
Architecture: all
-Depends: ${misc:Depends}, php-curl, php-json, php-mbstring, php-xml
-Recommends: apache2 | nginx | httpd, libapache2-mod-php | php-fpm | php-cgi
+Depends: ${misc:Depends}, ${phpcomposer:Debian-require}, php-curl, php-json, php-mbstring, php-xml
+Recommends: ${phpcomposer:Debian-recommend}, apache2 | nginx | httpd, libapache2-mod-php | php-fpm | php-cgi
+Suggests: ${phpcomposer:Debian-suggest}
Description: web service generating ATOM feeds for websites that don't have them
Provides a PHP web service which generates ATOM feeds for facebook, twitter,
youtube, flickr, google, instagram, pinterest and more than 130 other web
diff --git a/debian/rules b/debian/rules
index fbc17e0..2e2be8a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,6 @@
#!/usr/bin/make -f
%:
- dh $@
+ dh $@ --with phpcomposer
PHP_VERSION=$(shell phpquery -V | head -1)