summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPraveen Arimbrathodiyil <praveen@debian.org>2016-06-29 13:03:50 +0530
committerPraveen Arimbrathodiyil <praveen@debian.org>2016-06-29 13:03:50 +0530
commit0439a47ec9f390f8bb90a51212a09ff3b82d3e69 (patch)
tree51925e0c96f9b7d88d628a9ac4f6bf9b3c6e23e5
parent126cdd0b323d23979a8c555000acaaff051e8e7e (diff)
remove patch, update deps
-rw-r--r--debian/changelog1
-rw-r--r--debian/control6
-rw-r--r--debian/patches/fix-specs-for-ruby2_3.patch36
-rw-r--r--debian/patches/series1
4 files changed, 4 insertions, 40 deletions
diff --git a/debian/changelog b/debian/changelog
index 4bf0371..79793bd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
ruby-typhoeus (1.0.2-1) UNRELEASED; urgency=medium
* New upstream release
+ * Remove patch fix-specs-for-ruby2_3.patch (merged upstream)
-- Pirate Praveen <praveen@debian.org> Wed, 29 Jun 2016 12:47:14 +0530
diff --git a/debian/control b/debian/control
index 0f34400..6943390 100644
--- a/debian/control
+++ b/debian/control
@@ -6,13 +6,13 @@ Uploaders: Pirate Praveen <praveen@debian.org>
Build-Depends: debhelper (>= 9~),
gem2deb,
rake,
- ruby-ethon (>= 0.8.0),
+ ruby-ethon (>= 0.9.0~),
ruby-faraday,
ruby-json,
ruby-rack,
ruby-rspec,
ruby-sinatra
-Standards-Version: 3.9.7
+Standards-Version: 3.9.8
Vcs-Git: https://anonscm.debian.org/git/pkg-ruby-extras/ruby-typhoeus.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-ruby-extras/ruby-typhoeus.git
Homepage: https://github.com/typhoeus/typhoeus
@@ -23,7 +23,7 @@ Package: ruby-typhoeus
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
Depends: ruby | ruby-interpreter,
- ruby-ethon (>= 0.8.0),
+ ruby-ethon (>= 0.9.0~),
${misc:Depends},
${shlibs:Depends}
Description: parallel HTTP library on top of ethon
diff --git a/debian/patches/fix-specs-for-ruby2_3.patch b/debian/patches/fix-specs-for-ruby2_3.patch
deleted file mode 100644
index 47e395a..0000000
--- a/debian/patches/fix-specs-for-ruby2_3.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Description: Fix specs for Ruby 2.3
-Author: Sebastian Skalacki <skalee@gmail.com>
-Applied-Upstream: https://github.com/typhoeus/typhoeus/pull/514
-Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=816360
-Last-Update: 2016-03-15
---- a/spec/typhoeus/hydra/runnable_spec.rb
-+++ b/spec/typhoeus/hydra/runnable_spec.rb
-@@ -106,8 +106,9 @@
- end
- let(:second) { Typhoeus::Request.new("localhost:3001/second") }
- let(:requests) { [first] }
-+ let(:on_complete_counter){ double :mark => :twain }
-
-- before { Typhoeus.on_complete { |r| String.new(r.code) } }
-+ before { Typhoeus.on_complete { |r| on_complete_counter.mark } }
- after { Typhoeus.on_complete.clear; Typhoeus.before.clear }
-
- context "when real request" do
-@@ -115,7 +116,7 @@
- let(:options) { {} }
-
- it "calls on_complete callback once for every response" do
-- expect(String).to receive(:new).exactly(2).times
-+ expect(on_complete_counter).to receive(:mark).exactly(2).times
- hydra.run
- end
- end
-@@ -126,7 +127,7 @@
- before { Typhoeus.before{ |request| request.finish(Typhoeus::Response.new) } }
-
- it "simulates real multi run and adds and finishes both requests" do
-- expect(String).to receive(:new).exactly(2).times
-+ expect(on_complete_counter).to receive(:mark).exactly(2).times
- hydra.run
- end
- end
diff --git a/debian/patches/series b/debian/patches/series
index 1e4b6cf..005fb51 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
-fix-specs-for-ruby2_3.patch
remove-rubygems-bundler.patch